Velocità di scrittura lenta su ntfs

4

Quando scrivo alla mia partizione ntfs ottengo delle velocità molto basse (durante la lettura comunque ottengo le mie velocità massime):

589824   3%   60.20kB/s    0:04:06

Questo esempio sta usando

rsync --progress [File] [Destination]

Dove sto facendo una copia del file nella stessa directory.

Sto montando la mia partizione ntfs usando fstab:

/dev/sda6 /mnt/data ntfs-3guid=1000,gid=11000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

Non sono sicuro che ciò sia pertinente, ma di recente ho esaminato i suggerimenti Power Tweaking forniti Ubuntu wiki e credo che queste situazioni possano essere correlate.

Conf Grub:

GRUB_BACKGROUND=/boot/grub/gbackground.jpg
GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=0

Il tweak di potere che credo stia causando il problema è ALPM .

Nota: le mie velocità di scrittura sulla mia ntfs patition sono state assolutamente soddisfacenti fino a circa ieri quando ho iniziato a trafficare con il power tweak (s)

Sto utilizzando un'unità con più partizioni, quindi non può essere un errore hardware, anche perché il mio doppio avvio in Windows può accedere all'unità a velocità normale.

    
posta hamhut1066 19.07.2012 - 12:20

2 risposte

2

È l'opzione sync che mostri nella tua linea fstab che lo sta facendo. Questo è un problema comune quando si utilizza un'unità USB esterna che utilizza USBmount. Da /etc/usbmount/usbmount.conf :

#############################################################################
# WARNING!                                                                  #
#                                                                           #
# The "sync" option may not be a good choice to use with flash drives, as   #
# it forces a greater amount of writing operating on the drive. This makes  #
# the writing speed considerably lower and also leads to a faster wear out  #
# of the disk.                                                              #
#                                                                           #
# If you omit it, don't forget to use the command "sync" to synchronize the #
# data on your disk before removing the drive or you may experience data    #
# loss.                                                                     #
#                                                                           #
# It is highly recommended that you use the pumount command (as a regular   #
# user) before unplugging the device. It makes calling the "sync" command   #
# and mounting with the sync option unnecessary---this is similar to other  #
# operating system's "safely disconnect the device" option.                 #
#############################################################################

Quindi rimuovi l'opzione sync da fstab o modificala in async . Se usi hotplug cambia la seguente riga in /etc/usbmount/usbmount.conf da:

MOUNTOPTIONS="sync,noexec,nodev,noatime,nodiratime"

a

MOUNTOPTIONS="noexec,nodev,noatime,nodiratime"

E non dimenticare di smontare in sicurezza il tuo disco prima di scollegare.

    
risposta data beldaz 21.07.2014 - 12:04
0

Mi è successo una volta. Avevo modificato fstab per montare automaticamente la partizione NTFS automaticamente all'avvio. Il ripristino del file prima della modifica ha funzionato.

    
risposta data Akshit Baunthiyal 15.08.2012 - 18:53

Leggi altre domande sui tag