Lenovo X220 si riavvia invece di spegnersi

4

Quando spingo il pulsante di spegnimento nella finestra di spegnimento, il mio notebook (Lenovo X220) si riavvia.

Ho anche provato a eseguire "sudo shutdown -P now" dalla riga di comando - & gt; stesso risultato!

Prima di passare alla versione 11.10, tutto andava bene.

Qualcun altro sperimenta questo malfunzionamento? Qualche consiglio per farlo funzionare di nuovo?

    
posta lebenlechzer 19.10.2011 - 20:35

2 risposte

2

Sono qui su Xubuntu 11.10 con un i5 x20 e ho riscontrato lo stesso problema.

L'installazione di laptop-mode-tools (con aptitude install laptop-mode-tools --without-recommends ) l'ha risolto per me.

(trovato il suggerimento tramite link )

Ho trovato un'altra soluzione che non coinvolge gli strumenti in modalità laptop. Forse funziona per gli altri. Il problema sembra si verifica quando viene abilitata la gestione dell'alimentazione per i dispositivi PCI (e) (impostata su "auto"). Ecco due modi per verificare che:

  1. esegui powertop , passa alla scheda "Tunables" e verifica se le voci "Runtime PM per PCI *" sono contrassegnate come "Buono"
  2. cat /sys/bus/pci/devices/*/power/control e vediamo se emette alcuni valori "auto". "auto" causa i problemi di spegnimento sulla mia macchina mentre "on" non lo fa.

Ho creato uno script init.d per gestire quello (e altre cose come l'impostazione di trebbiti di carica della batteria e simili), disponibile tramite pastebin .

Nota:

  • Lo script funziona correttamente sulla mia macchina. Ciò non significa che verrà eseguito su altri a causa della mancanza di programmi, ecc.
  • Lo script fa più di (potenzialmente) aggirare il problema di arresto, quindi per favore leggi prima
  • Non sono sicuro che "auto" porti alcun vantaggio;)

Spero che ti aiuti.

    
risposta data user30817 26.10.2011 - 23:45
0

Ho installato gli strumenti in modalità portatile, ma il problema si verifica comunque. Oneiric con gnome / unity, su un i7 x220. Accade se faccio sudo shutdown -h now o shutdown tramite il gui. La mia unica soluzione è tenere premuto il pulsante di accensione dopo il riavvio.

    
risposta data user31872 02.11.2011 - 14:51

Leggi altre domande sui tag