Wireless è disabilitato

4

Recentemente è ripetuto costantemente !! La rete è disattivata visualizzata nell'icona di rete, il mio sistema operativo ubuntu 10.10.
Mentre navigo su NET dopo un po '(potrebbe essere 2 ore o forse un giorno) si disconnette e quindi non può più connettersi al WiFi fino al riavvio della macchina !!.
Ho cercato e provato molte soluzioni, ma nessuna utile sembra risolvere il problema :(
ecco uno in questo forum up-as-disabled-how-can-i-get-it-work è lo stesso problema spiegato qui ma non può risolvere come menzionato !, anche ogni thread / domanda relativo al problema trovato qui I provato ma senza speranza.
Comando "Rfkill list all":

1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

anche il pulsante Wireless è acceso!
un altro comando:

sudo ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

* comando "lshw":

*-network               
   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: [email protected]:02:00.0
   logical name: eth0
   version: 01
   serial: 00:19:db:3d:d1:18
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list rom ethernet physical
   configuration: broadcast=yes driver=r8169 driverversion=2.3LK-NAPI ip=192.168.1.102 latency=0 multicast=yes
   resources: irq:43 ioport:d800(size=256) memory:fe2ff000-fe2fffff memory:fe2c0000-fe2dffff


 *-network:0 DISABLED
       description: Wireless interface
       physical id: 1
       bus info: [email protected]:6
       logical name: wlan0
       serial: 00:19:db:9d:d7:c3
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt73usb driverversion=2.6.35-32-generic firmware=N/A multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: vboxnet0
       serial: 0a:00:27:00:00:00
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes

* del comando "lspci":

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

per favore aiuto .... qualsiasi suggerimento sarà apprezzato.

    
posta wisdom 08.02.2012 - 14:20

4 risposte

2

se rfkill list mostra 1 è hardblock: hai provato a correre

rfkill unblock 1

che funziona per me (ma nel mio caso devo eseguire rfkill unblock 0 e rfkill unblock 2 , il primo è il mio interruttore wireless, il secondo è l'interruttore wifi)

    
risposta data cfstras 08.02.2012 - 16:10
0

Inserirò un bug su launchpad per segnalare questo errore intermittente.

Nel frattempo, alcune delle potenziali cose che puoi provare.

Suggerimento 1.

Avvia usando un kernel precedente - premi SHIFT al momento dell'avvio per visualizzare il tuo Grub. Scegli l'opzione delle versioni precedenti e seleziona un kernel precedente

Suggerimento 2

Rilascia e avvia la tua connessione LAN tramite

ifconfig wlan0 down 
ifconfig wlan0 up

Suggerimento 3

Forza il riavvio del servizio gestore di rete

sudo service network-manager restart

Suggerimento 4

Scarica e ricarica il modello del kernel e riavvia il gestore di rete:

sudo modprobe -r rt73usb
sudo modprobe rt73usb
sudo service network-manager restart
    
risposta data fossfreedom 08.02.2012 - 15:56
0

Prova ad avviare il tuo computer:

 press f2? to get into bios

 press f9? to reset to default settings

press f10? to save settings

Controlla se sei ancora bloccato.

[i tasti sono per il mio laptop che non è un Dell, potrebbe essere necessario controllare quali sono i tuoi]

    
risposta data Joshua Siret 17.06.2012 - 18:15
0

Per coloro che hanno provato tutto come me, incluso

rfkill list

suggerito da @cfstras, potresti provare qualcosa di ridicolmente semplice.

Nel mio caso l'output rfkill list era:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Così ho provato:

rfkill unblock 1

E questo non ha aiutato. Dopo aver cercato su Google ho risolto il problema semplicemente premendo Fn+PrtScr che ha l'icona della rete wireless. (Ho Dell XPS 13 9343, ma sul tuo laptop potrebbe essere su un altro pulsante). HTH.

    
risposta data valk 24.09.2015 - 07:57

Leggi altre domande sui tag