Crash WebGL crasha su Ubuntu 16.04

4

Recentemente ho aggiornato da Linux Mint 17.3 MATE (Ubuntu 14.04) a Ubuntu 16.04. Prima dell'aggiornamento, WebGL funzionava correttamente in Chrome. Le pagine con WebGL semplice, come get.webgl.org, funzionano ancora, ma ora cercano di accedere ad alcune pagine, come quelle su Sandbox GLSL, si blocca il processo della GPU e una barra gialla appare nella parte superiore della pagina che dice "WebGL ha colpito un intoppo." Se eseguo il crash della GPU abbastanza volte, tutte le voci precedentemente disponibili nella pagina chrome: // gpu diventano "Solo software, accelerazione hardware non disponibile" fino al riavvio di Chrome.

Come posso risolvere questo problema?

Attualmente utilizzo Chrome 50.0.2661.94 51.0.2704.63 e driver proprietari NVIDIA 340.96 361.45.11.

Ecco un'istantanea della pagina chrome: // gpu prima che il processo GPU si interrompesse: link

Ecco la pagina dopo che ho interrotto il processo GPU alcune volte: link

Cose che ho provato

  • Riavvio (più volte)
  • Diverse versioni di driver NVIDIA proprietari (361.42, 340.96, 358.16, 364.19, 304.131 e 361.45.11), alcuni da questo PPA
  • Ripristino dei miei flag personalizzati in chrome: // flags e attivazione / disattivazione dell'opzione override

Informazioni aggiuntive

  • Il processo GPU di Chrome si blocca e si blocca anche quando apro gli strumenti per sviluppatori, che sono davvero fastidiosi
posta Andrew Sun 28.04.2016 - 21:44

3 risposte

1

La combinazione della versione di Chrome 52.0.2743.116 e dei driver NVIDIA 361.45.18 ha risolto i problemi di arresto anomalo con WebGL. Potrei sbagliarmi, ma questo commit sembra correlato alla risoluzione del problema.

    
risposta data Andrew Sun 23.08.2016 - 03:48
0

Alla ricerca di una risposta ho trovato questo link

Modifica della flag # ignore-gpu-blacklist attivando l'opzione "Esegui l'override della lista di rendering del software" (in inglese "Ignora la lista di rendering del software") su chrome: // flags, e il solo riavvio di Chrome non funziona: devi assicurarti che tutti i processi di Chrome siano stati uccisi. Quindi, chiudi Chrome, su un emulatore di terminale esegui killall chrome e riavvia il programma. Ora link segnala che questa macchina supporta WebGL 1.

Purtroppo, questo non ha risolto tutti i problemi con WebGL, almeno in un test in link che funziona OK su Firefox 46 su questa macchina. Ma forse è sufficiente sulla macchina di qualcun altro.

    
risposta data GiovanniES 07.05.2016 - 21:47
0

Il passaggio al driver binario legacy (304.131) ha funzionato per me. Nota che è 304, non 340 (all'inizio pensavo che fossero la stessa versione). Ora posso utilizzare nuovamente WebGL su Chrome (in Google Maps).

Istruzioni per i posteri:

  • Apri software e amp; Aggiornamenti & gt; Driver aggiuntivi
  • Seleziona utilizzando il driver binario legacy NVIDIA - versione 304.131 da nvidia-304 (proprietario)
  • Fai clic su Applica modifiche

Devo anche menzionare che la mia scheda video viene rilevata come NVIDIA GF108M [NVS 5400M]. Sto utilizzando Ubuntu 16.04 su un ThinkPad T530 con grafica discreta abilitata nel BIOS.

    
risposta data Mike Percy 08.05.2016 - 06:22

Leggi altre domande sui tag