Synaptic e aptitude interrotte dopo l'aggiornamento dal 15.10 al 16.04

4

dopo aver aggiornato Ubuntu Gnome 15.10 (Wily Werewolf) a 16.04 (Xenial Xerus), non posso avviare synaptic o aptitude per l'installazione di nuovo software, e anche apt-get install any non funziona. Ecco l'errore che ottengo sempre:

% Bl0ck_qu0te%

Ho letto molto su questo errore su Google, ecc, ma le soluzioni proposte sul web funzionano solo per le versioni precedenti di Ubuntu o Debian. Quello che ho provato, ad es. stava controllando il valore di APT :: Default-Release in /etc/apt/apt.conf , ma non è impostato lì, non è impostato in nessun file di testo in /etc/apt/ o in una qualsiasi delle sue sottodirectory. Ho rimosso tutti i file dalla directory /etc/apt/sources.list.d , perché questi erano correlati alle versioni di Ubuntu precedenti.

Altre idee?

P.S. 1: Un po 'più di informazioni sul mio ambiente:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial

P.S. 2: Output da sudo apt edit-sources (righe commentate rimosse):

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse

deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://archive.canonical.com/ xenial partner
    
posta Gerhard Hagerer 11.05.2016 - 09:11

3 risposte

0

Se hai problemi con% co_de "bloccati" o con i programmi di livello superiore apt o aptitude , potrebbe essere necessario pulire la cache di apt.

Questo è particolarmente vero dopo un aggiornamento della distribuzione.

sudo apt clean

è veloce e facile e aiuta con molti sistemi apt bloccati. Lo faccio regolarmente dopo un sacco di aggiornamenti, o dopo un dist-upgrade.

    
risposta data emk2203 13.05.2016 - 15:35
1

Apri /etc/apt/apt.conf.d/01ubuntu usando nano , come

sudo nano /etc/apt/apt.conf.d/01ubuntu

Quindi, digita quanto segue:

APT::Default-Release "xenial";

Pulisci la tua cache apt eseguendo:

sudo rm -rfv /var/lib/apt/lists/*

Quindi crea la cartella partial che è stata rimossa dal comando precedente:

sudo mkdir -pv /var/lib/apt/lists/partial

Per assicurarti di aver pulito i tuoi elenchi, esegui il seguente comando:

sudo apt clean && sudo apt autoclean

Ora aggiorna le informazioni sul tuo repository:

sudo apt update --fix-missing

Questo dovrebbe correggere i tuoi errori.

    
risposta data Abhimanyu Saharan 13.05.2016 - 16:33
0

quel mirror è stato rotto fino a questa mattina, vedi la data e l'ora nelle cartelle Xenial. Dovrebbe funzionare ora.

http://ubuntu.mirror.lrz.de/ubuntu/dists/

È preferibile utilizzare il redirector standard per il tuo paese perché non avrebbe incluso un mirror rotto.

http://de.archive.ubuntu.com/ubuntu/
    
risposta data Amias 13.05.2016 - 15:34

Leggi altre domande sui tag