Come posso far sì che APT ignori le dipendenze non soddisfatte?

4

Il mio apt-get si sta attualmente lamentando delle dipendenze non soddisfatte (e si rifiuta di fare qualsiasi cosa finché non le risolvo):

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libavcodec53 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 libva-dev : Depends: libva1 (>= 1.0.12) but 0.31.1-1+sds4 is installed
 libva-glx1 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 libva-tpi1 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 vainfo : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
E: Unmet dependencies. Try using -f.

Il fatto è che ho bisogno di quella specifica versione di libva1. Qualunque cosa sia più recente non funziona con mplayer-vaapi. Le presunte dipendenze non soddisfatte non sembrano avere effetti negativi sul mio sistema (oltre a rompere APT), quindi c'è un modo per far sì che apt-get li ignori e faccia semplicemente quello che gli viene detto?

    
posta bessman 03.03.2012 - 23:43

1 risposta

2

Se hai una particolare applicazione che non vuoi aggiornare, "pinla" o "blocca" usando synaptic.

Evidenzia la selezione & gt; Vai a Pacchetto & gt; scorrere verso il basso fino a "Blocca versione" e fare clic

    
risposta data Ringtail 04.03.2012 - 00:46

Leggi altre domande sui tag