Impossibile connettersi a Internet con Dongle 3G USB per ISP specifico

4

Uso il dongle USB 3G per Internet. In precedenza stavo usando Tata Docomo (India) come fornitore e Internet funzionava bene. Ora sono passato a BSNL, ma non riesco a collegarmi a Internet su Ubuntu. Tuttavia, ho controllato le impostazioni del punto di accesso e altre configurazioni richieste per BSNL, e funziona perfettamente con lo stesso Dongle su Windows 7. Inoltre, sono in grado di connettere Internet con altri provider su Ubuntu, ma il problema persiste solo con Ubuntu. Il punto di accesso per BSNL nella mia regione è bsnlnet . Infatti, configuro il dongle con BSNL usando la procedura guidata di configurazione di rete predefinita che si apre quando viene collegato il dongle USB.

Quando Dongle è collegato e configurato con BSNL, posso vedere la potenza della rete nel menu Messaggi, nella categoria Mobile Broadband, di Ubuntu (nota: l'icona della mia rete mostra ancora lo stato "non connesso"). E quando provo ad usare la connessione che ho creato, non riesce a connettersi. Finora, ho provato a utilizzare lo script Sakis3g che mi è venuto in mente mentre giravo su questo problema su altri forum, ma non ha funzionato. Mi sono anche assicurato che non ci fosse alcuna configurazione speciale per BSNL sulla mia installazione di Windows 7, e comunque funziona bene, il problema è solo con Ubuntu.

Come posso risolverlo?

Aggiornamento:

Sebbene non sia stato possibile risolvere il problema in Ubuntu 11.10, esiste ancora in 12.04 . Spero che qualcuno trovi una soluzione e la pubblichi, dato che voglio diventare utente Ubuntu a tempo pieno, ma l'unico modo per connettere internet in Ubuntu per ora è usare un altro provider.

E scommetto che il problema abbia qualcosa a che fare con i provider di banda di rete. Poiché Tata Docomo e BSNL operano su diverse bande GSM, mentre in Windows, il partner Huawei Mobile gestisce questo e posso utilizzare qualsiasi provider GSM per connettersi a Internet, suppongo che questo non stia accadendo con Ubuntu, e posso usare solo Tata Docomo e altri fornitori che operano sulla stessa banda.

    
posta Kushal 05.03.2012 - 05:17

4 risposte

1

Dai un'occhiata a questa guida non ufficiale su "Come impostare la banda larga mobile come la BSNL 3G USB DataCard su Ubuntu 11.10".

Inoltre, secondo questa risposta , c'è un bug riguardante due dongle USB, Huawei E220 ed E1550, su Ubuntu 11.10. La soluzione suggerita nel thread del bug è:

  1. Collega il tuo dongle usb;
  2. esegui nel terminale: sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R
  3. Quindi scollegare e ricollegare il dongle e ora si connetterà.

Spero che sia d'aiuto e non dimenticare di contrassegnare l'errore che ti riguarda, al fine di risolverlo il prima possibile.

Se non sei ancora in grado di collegarti a Internet, puoi provare la soluzione proposta in questo domanda simile .

    
risposta data heiko81 05.03.2012 - 10:20
1

Ho avuto un problema con HUAWEI E169 & amp; bsnl l'anno scorso. Si stava disconnettendo subito dopo averlo mostrato che era connesso. Fai la seguente speriamo, risolva anche per te.

Suppongo che tu sia un utente esperto, ti preghiamo di perdonare qualsiasi errore nel passaggio 1. (Non ho accesso a Ubuntu in questo momento)

  1. Fai clic su Network manger , fai clic su Edit Settings . Quindi vai a mobile broadband e fai clic su edit della tua connessione bsnl esistente.

  2. Sulla PPP Setting tab scegli

    • Autenticazione: CHAP deseleziona solo il resto.
    • Compressione: assicurati di aver spuntato quanto segue:
      1. Consenti compressione dati BSD
      2. Permetti la compressione dei dati di deflate
      3. Utilizza la compressione dell'intestazione TCP
  3. Prova a riconnetterti.

Prova un altro metodo di autenticazione se quanto sopra non funziona. Solo uno alla volta. BSNL è l'unico fornitore che ha questo tipo di problema.

    
risposta data Web-E 08.05.2012 - 11:30
0

0 voto negativo

uso wvdial per connettermi al mio modem 3g come di seguito:

install wvdial : sudo apt-get install wvdial

edit the wvdial.comf file by any text editor say gedit by below command:

sudo gedit /etc/wvdial.conf

copy paste the following lines in wvdial.conf

[Dialer a]

Modem Type = Analog Modem

Phone = *99#

ISDN = 0

Baud = 460800

Username = " "

Password = " "

Modem = /dev/ttyUSB0

Init1 = ATZ

Init2 = at+cgdcont=1,"ip","your apn"

Stupid Mode = 1

4 connetti usando, (puoi cambiare il nome come vuoi sostituendo un in sopra wvdial.conf)

wvdial a

(basta aggiungere apn secondo isp che stai usando come aircelgprs per aircel, bsnnet per bsnl ecc. nel file wvial.conf al posto di "your apn")

    
risposta data gunjan parashar 12.05.2013 - 02:07
0

sudo wvdial Defaults - & gt; WvDial: dialer Internet versione 1.61 - & gt; Impossibile aprire / dev / ttyUSB0: nessun file o directory di questo tipo - & gt; Impossibile aprire / dev / ttyUSB0: nessun file o directory di questo tipo - & gt; Impossibile aprire / dev / ttyUSB0: nessun file o directory

    
risposta data Supraim Samantray 03.03.2014 - 08:14

Leggi altre domande sui tag