php5 e phpmyadmin non si installano

4

Ho installato mysql, mysql-server, apache2 e molti altri. Può essere che ho installato alcuni PPA o programmi sbagliati che causano questo problema. Fondamentalmente, ho bisogno di eseguire il server locale (ad esempio per wordpress). Quindi ho bisogno di localhost / phpmyadmin. In qualche modo localhost funziona (mostra la pagina predefinita) ma localhost / phpmyadmin non funziona.

Quando ho provato a sudo apt-get install phpmyadmin , restituisce l'output seguente

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

phpmyadmin : Depends: libapache2-mod-php5 but it is not going to be installed or
                       libapache2-mod-php5filter but it is not going to be installed or
                       php5-cgi but it is not going to be installed or
                       php5-fpm but it is not going to be installed or
                       php5 but it is not going to be installed
              Depends: php5-mysql but it is not going to be installed or
                       php5-mysqli but it is not installable or
                       php5-mysqlnd but it is not going to be installed
              Depends: php-gettext but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Quando ho provato sudo apt-get install php5 libapache2-mod-php5 , dà il seguente errore

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ancora una volta, ho provato ad installare i php-comuni mancanti di sudo apt-get install php5-commom , mostra php5-common è già la sua versione più recente. Ecco l'output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:/$ sudo apt-get install php5-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

Quindi, ragazzi ho bisogno del tuo aiuto per installare phpmyadmin.

Aggiorna Ecco un output di grep -R --include '*.list' '^deb ' /etc/apt

/etc/apt/sources.list:deb cdrom:[Ubuntu 14.04.3 LTS _Trusty Tahr_ - Beta amd64 (20150805)]/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security multiverse
/etc/apt/sources.list:deb http://extras.ubuntu.com/ubuntu trusty main
/etc/apt/sources.list:deb http://deb.torproject.org/torproject.org trusty main
/etc/apt/sources.list.d/upubuntu-com-office-trusty.list:deb http://ppa.launchpad.net/upubuntu-com/office/ubuntu trusty main
/etc/apt/sources.list.d/google.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/webupd8team-sublime-text-3-trusty.list:deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-java-trusty.list:deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
/etc/apt/sources.list.d/google-chrome.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/cordova-ubuntu-ppa-trusty.list:deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-tor-browser-trusty.list:deb http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu trusty main
/etc/apt/sources.list.d/nodesource.list:deb https://deb.nodesource.com/node_5.x trusty main
/etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list:deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main

e output di apt-cache policy php5-common

php5-common:
  Installed: 5.5.9+dfsg-1ubuntu4.14
  Candidate: 5.5.9+dfsg-1ubuntu4.14
  Version table:
 *** 5.5.9+dfsg-1ubuntu4.14 0
        100 /var/lib/dpkg/status
     5.5.9+dfsg-1ubuntu4.5 0
        500 http://ubuntu.excellmedia.net/archive/ trusty-updates/main amd64 Packages
        500 http://ubuntu.excellmedia.net/archive/ trusty-security/main amd64 Packages
     5.5.9+dfsg-1ubuntu4 0
        500 http://ubuntu.excellmedia.net/archive/ trusty/main amd64 Packages

UPDATE 2 Ecco un output di aptitude search '?narrow(?installed, !?version(CANDIDATE))'

W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to update the package lists to correct these missing files
i   google-chrome-stable            - The web browser from Google               
i   nodejs                          - Node.js event-based server-side javascript
i   oracle-java8-installer          - Oracle Java(TM) Development Kit (JDK) 8   
i   oracle-java8-set-default        - Set Oracle JDK 8 as default Java          
i   tor-browser                     - Tor Browser Bundle                        
    
posta Madan Bhandari 09.03.2016 - 10:38

1 risposta

1

La tua versione installata di php5-common non è compatibile con i pacchetti che desideri installare.

Il motivo è molto probabilmente un PPA che hai aggiunto, quindi hai installato una versione più recente di php5-common (e forse altri pacchetti) da esso e rimosso o disattivato di nuovo il PPA.

Ciò che dobbiamo fare ora è rimuovere quelle versioni "troppo nuove" dalla cache del pacchetto per evitare un'altra reinstallazione accidentale di esse e quindi effettuare il downgrade del pacchetto php5-common alla versione disponibile dal repository ufficiale:

sudo apt-get clean    
sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5

Solo se non ha funzionato ancora, esegui i comandi di seguito. L'ultimo è lo stesso di sopra.

sudo rm -rf /var/lib/apt/lists
sudo apt-get update
sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5
    
risposta data Byte Commander 10.03.2016 - 18:52