Il modo migliore per aggiornare il kernel in Ubuntu Desktop 14.04.3 LTS

4

A causa del mio problema con il Wi-Fi come menzionato qui devo aggiorna il mio kernel alla 4.2.x. seguendo questi comandi:

$ cd /tmp  
$ wget \  kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205_4.2.5-040205.201510270124_all.deb \  kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205-generic_4.2.5-040205.201510270124_amd64.deb \  kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-image-4.2.5-040205-generic_4.2.5-040205.201510270124_amd64.deb  
$ sudo dpkg -i linux-headers-4.2*.deb linux-image-4.2*.deb

E so che posso rimuoverlo usando:

sudo apt-get remove linux-headers-4.2* linux-image-4.2*

Questo ha risolto il problema del mio driver wifi (Intel wifi 3165). Ma ho imparato che ho il kernel da mainline e non è una buona idea dato che non riceverò altri aggiornamenti ecc ... Allora, qual è il modo giusto per aggiornare il kernel? Ho sentito che dovrei usare:

sudo apt-get install linux-generic-lts-wily

Vuoi sapere esattamente cosa devo fare per aggiornare correttamente il kernel? Per me è molto importante come se non avessi questa versione del kernel, il mio wifi non funziona. Inoltre voglio sapere cosa succederà al mio Ubuntu Desktop 14.04.3 LTS con questo kernel aggiornato quando la nuova versione LTS (16.04 LTS) arriverà ad aprile 2016?

Ho un altro vincolo: Ho bisogno di essere in versione LTS come alcuni degli strumenti software / prodotti (DSE e RLEC) che uso - richiede solo la versione 14.04.3 LTS. Ecco perché non puoi andare a 15.10

    
posta Ashu 16.02.2016 - 19:35

1 risposta

1

L'installazione da repository di Ubuntu è preferibile.

Questo installerà un kernel di Ubuntu supportato e riceverà gli aggiornamenti.

Se installi un kernel mainline, potresti avere problemi con alcuni driver e dovrai aggiornarlo manualmente.

Il kernel di Ubuntu 4.2 sarà predefinito nella prossima versione "LTS" di LTS 14.04.4 prevista per febbraio 2016.

Non ci dovrebbero essere problemi nell'aggiornamento alla 16.04.

Installando linux-generic-lts-wily ora si installa quel kernel un po 'prima di quanto verrà rilasciato per tutte le nuove installazioni LTS.

Puoi leggere ulteriori informazioni su Stack HWE .

    
risposta data Pilot6 16.02.2016 - 19:41

Leggi altre domande sui tag