Ubuntu 15.04 ha una connettività PPTP molto scarsa

4

In circostanze universitarie, dovrei collegarmi a una VPN PPTP per accedere a Internet. Quindi un client PPTP ad alte prestazioni e privo di bug è per me un'essenza.

Quando usavo Ubuntu 14.04 e 14.10, il client PPTP funzionava correttamente. Ma come ho sostituito la mia Ubuntu entro il 15.04, la mia connettività PPTP è andata incontro a una pessima esperienza.

Che cosa sto vivendo attualmente:

Quando mi collego al PPTP facendo clic sul nome VPN in nm-applet , si connette in un modo usuale e mi fornisce una buona connettività solo da 30 a 60 sec, ma da questo momento in poi la velocità di connessione scende drasticamente in modo tale che quando voglio caricare una pagina web viene caricato solo il suo titolo e il resto della pagina non verrà mostrato.

Quando disconnetto e ricollego, tale comportamento verrà ripetuto.

Le mie domande:

  • Qualcuno può suggerirmi un modo per migliorare il mio client PPTP predefinito?
  • Posso utilizzare i client PPTP di terze parti? Se è così, qual è il migliore?

Contesto:

  • pptp versione: 1.7.2
  • Interfaccia sottostante: Intel Centrino Wireless N 2230
posta Hi I'm Frogatto 07.05.2015 - 15:31

1 risposta

1

Sembra che potrebbe essere mitigato aggiornando il client pptp alla versione 1.8.0. Le istruzioni sono elencate come segue.

  

Istruzioni per l'installazione - dettagliate

     
  1. installa PPP e assicurati che funzioni.

         

    Sulla maggior parte delle distribuzioni, usa il pacchetto chiamato ppp o pppd.

         

    Se il tuo server PPTP richiede MPPE, assicurati che il programma pppd      è stato costruito con supporto MPPE e MS-CHAP. PPP da      la versione 2.4.2 in poi ha questo supporto. PPP potrebbe richiedere      supporto del kernel per MPPE, che potrebbe richiedere il patching del tuo      kernel.

  2.   
  3. verifica che il programma pppd si trovi nella directory / usr / sbin /.

    On some distributions, it is in /usr/bin, or somewhere else.
    If it isn't in the default directory, edit the Makefile, and
    change the PPPD variable to point at the pppd program.
    
    You may even want to run a separate pppd program with MPPE
    support.
    
  4.   
  5. compilare

    Type 'make'.  This should generate the 'pptp' executable.
    
  6.   
  7. installa i binari

         

    Scrivi 'make install' per avere il programma e la pagina di manuale   installato.

  8.   
    
risposta data Hi I'm Frogatto 09.05.2015 - 10:52

Leggi altre domande sui tag