"ImportError: nessun modulo chiamato XKit.xutils" durante la rimozione di nvidia-current

4

Il mio PC si spegne durante l'aggiornamento dalla 12.04 alla 12.10. Tutto sembra funzionare ma non riesco a installare gli aggiornamenti mancanti. Mi dice sempre di eseguire apt-get install -f , ma quando lo faccio dice semplicemente:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  espeak gcc-4.6-base:i386 gir1.2-notify-0.7 libcamel-1.2-29 libebook-1.2-12
  libedataserver-1.2-15 libgconf2-4 libgnome-bluetooth8 libgnome-menu2
  libgnomekbd7 libgomp1:i386 libgweather-3-0 libimobiledevice2 libindicate5
  libkpathsea5 libpoppler19 libusbmuxd1 python-gmenu
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  nvidia-current-updates xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-qxl
  xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-vesa xserver-xorg-video-vmware
Vorgeschlagene Pakete:
  xfonts-100dpi xfonts-75dpi gpointing-device-settings touchfreeze
  firmware-linux
Die folgenden Pakete werden ENTFERNT:
  nvidia-current
Die folgenden Pakete werden aktualisiert (Upgrade):
  nvidia-current-updates xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-qxl
  xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-vesa xserver-xorg-video-vmware
20 aktualisiert, 0 neu installiert, 1 zu entfernen und 133 nicht aktualisiert.
8 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 70,6 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 184 MB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]? j
(Lese Datenbank ... 242727 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von nvidia-current ...
Removing all DKMS Modules
Error! There are no instances of module: nvidia-current
295.40 located in the DKMS tree.
Done.
Traceback (most recent call last):
  File "/usr/bin/quirks-handler", line 26, in <module>
    import Quirks.quirkapplier
  File "/usr/lib/python2.7/dist-packages/Quirks/quirkapplier.py", line 26, in <module>
    import XKit.xutils
ImportError: No module named XKit.xutils
dpkg: Fehler beim Bearbeiten von nvidia-current (--remove):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 1 zurück
Trigger für bamfdaemon werden verarbeitet ...
Rebuilding /usr/share/applications/bamf.index...
Trigger für libc-bin werden verarbeitet ...
ldconfig deferred processing now taking place
Fehler traten auf beim Bearbeiten von:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)

Quando tento di rimuovere nvidia-current, mi dice di eseguire apt-get install -f .

Ragazzi ne avete idea? Non voglio reinstallare tutto il mio sistema, ho bisogno di molto tempo per crittografare di nuovo tutto e così via.

    
posta UnknownDude 21.10.2012 - 18:38

2 risposte

3

Ho avuto lo stesso problema. Sembra /usr/lib/python2.7/dist-packages/Quirks/quirkapplier.py reference xkit.xutils with this syntax : XKit.xutils (maiuscolo all'inizio)

Do una prova a cambiarlo per una sintassi in minuscolo mentre trovo altri riferimenti in altre librerie con questa sintassi.

    
risposta data Django Janny 16.01.2013 - 21:43
-1

Prova ad eseguire:

sudo apt-get update -f
sudo apt-get -f install

Se non funziona installa aptitude:

sudo apt-get install aptitude 

ed esegui

sudo apt-get safe-upgrade.

C'è una soluzione per riparare i pacchetti danneggiati qui: cercando di sovrascrivere '/ usr / bin / opencv_haartraining', che è anche nel pacchetto libopencv2.3-bin 2.3.1 + svn6514 + branch23-12 ~ onirico

sudo dpkg --configure -a
sudo apt-get install -f

Se il problema di un pacchetto guasto esiste ancora, la soluzione è modificare manualmente il file di stato di dpkg.

sudo -H gedit /var/lib/dpkg/status  #you can use vi or nano instead of gedit

Individua il pacchetto corrotto e rimuovi l'intero blocco di informazioni su di esso e salva il file. Personalmente raccomanderei a tutti di fare una nuova installazione invece di aggiornare e creare una cartella home dedicata in modo da non perdere alcuna informazione quando si reinstalla Ubuntu. Ho avuto una brutta esperienza aggiornando alla nuova versione ... Il mio notebook si è spento durante il processo e c'erano errori similari ai tuoi.

    
risposta data polarkatenuchie 22.10.2012 - 17:06

Leggi altre domande sui tag