non può connettersi con huawei e173 dopo l'aggiornamento a 12.10 utilizzando il gestore di rete

4

Poiché l'aggiornamento dalla 12.04 alla 12.10 non riesco a connettermi a Internet utilizzando il modem a banda larga mobile Huawei e173. Ha funzionato in precedenza senza problemi e ora sembra essere riconosciuto correttamente (almeno le sue connessioni sono visualizzate nell'applet gestore di rete) e, dopo aver selezionato manualmente la connessione, avvia la procedura di connessione. Dopo circa 20 secondi ritorna allo stato disconnesso.

Dopo aver navigato su Internet, ho trovato il gestore di rete in esecuzione con:

NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon

Dopo aver inserito il modem, ottengo:

NetworkManager[507]: <warn> (ttyUSB2): failed to look up interface index
NetworkManager[507]: <info> (ttyUSB2): new GSM/UMTS device (driver: 'option1' ifindex: 0)
NetworkManager[507]: <info> (ttyUSB2): exported as /org/freedesktop/NetworkManager/Devices/2
NetworkManager[507]: <info> (ttyUSB2): now managed
NetworkManager[507]: <info> (ttyUSB2): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
NetworkManager[507]: <info> (ttyUSB2): deactivating device (reason 'managed') [2]
NetworkManager[507]: <info> (ttyUSB2): device state change: unavailable -> disconnected (reason 'none') [20 30 0]

dove "impossibile cercare l'indice dell'interfaccia" sembra essere sospetto.

Dopo aver avviato la connessione:

NetworkManager[507]: <info> Activation (ttyUSB2) starting connection 'Plus - Dostęp standardowy'
NetworkManager[507]: <info> (ttyUSB2): device state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
NetworkManager[507]: <info> (ttyUSB2): device state change: prepare -> need-auth (reason 'none') [40 60 0]
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
NetworkManager[507]: <info> (ttyUSB2): device state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[507]: <info> WWAN now enabled by management service
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) starting...
NetworkManager[507]: <info> (ttyUSB2): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) successful.
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) complete.
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 3 of 5 (IP Configure Start) started...
NetworkManager[507]: <info> (ttyUSB2): device state change: config -> ip-config (reason 'none') [50 70 0]
NetworkManager[507]: <info> starting PPP connection
NetworkManager[507]: <info> pppd started with pid 663
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 3 of 5 (IP Configure Start) complete.
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv6 Configure Timeout) started...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Plugin /usr/lib/pppd/2.4.5/nm-pppd-plugin.so loaded.
** Message: nm-ppp-plugin: (plugin_init): initializing
** Message: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
Removed stale lock on ttyUSB2 (pid 32146)
using channel 23
NetworkManager[507]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
NetworkManager[507]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
NetworkManager[507]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB2
** Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]
NetworkManager[507]: <warn> pppd timed out or didn't initialize our dbus module
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv4 Configure Timeout) started...
NetworkManager[507]: <info> (ttyUSB2): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
NetworkManager[507]: <warn> Activation (ttyUSB2) failed for connection 'Plus - Dostęp standardowy'
NetworkManager[507]: <info> Activation (ttyUSB2) Stage 4 of 5 (IPv4 Configure Timeout) complete.
NetworkManager[507]: <info> (ttyUSB2): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[507]: <info> (ttyUSB2): deactivating device (reason 'none') [0]
Terminating on signal 15
** Message: nm-ppp-plugin: (nm_phasechange): status 10 / phase 'terminate'
sent [LCP TermReq id=0x2 "User request"]
NetworkManager[507]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)

dove ripetuto:

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x64b4024a> <pcomp> <accomp>]

dura circa 20 secondi.

Ho provato a eseguire il downgrade del gestore di rete, ma non sono riuscito a causa di molte dipendenze.

Qualcuno può indicarmi una soluzione o dire cosa dovrei fare per approfondire il problema?

    
posta user104195 03.11.2012 - 15:24

3 risposte

2

Questo è accaduto a causa di bug (o bug) nel ModemManager 0.6.0.0 fornito con Ubuntu 12.10. È possibile rimuovere questa versione del gestore modem e eseguire il downgrade in 0.5.2.

Per verificare la versione del gestore modem: dpkg -s modemmanager

scarica la versione 0.5.2: link 64 --- i386

    
risposta data Chandana 14.11.2012 - 18:11
0

questo è un link al bug con una correzione: link

    
risposta data schettino72 11.03.2013 - 16:51
0

se provi tutte le opzioni per installare Huawei E176 su Ubuntu 12.10 e non ottenere. Ci sono spiegazioni su questo blog, con idee alternative da installare, e se hai bisogno di supporto, è possibile, contatta il blogger. Il testo è in portoghese, se il traduttore di Google non ti aiuta, il creatore del blog può provare: link

    
risposta data Isaac 18.04.2013 - 09:34

Leggi altre domande sui tag