Come riprendere l'aggiornamento interrotto dal 14.10 al 15.04?

6

Prima dell'aggiornamento, il mio file bashrc è stato modificato per aggiungere una configurazione Path.

Durante l'esecuzione di do-release-upgrade tutto andava bene finché non veniva richiesto un messaggio sullo stato del file bashrc e veniva visualizzato un menu di opzioni.

Dal menu, ho scelto l'opzione "Confronta le modifiche" e l'unica differenza era la mia precedente modifica. Nessun problema.

Ecco il problema: I ctrl-c e l'intero aggiornamento interrotto. Successivamente, ho riavviato il mio computer e da quel momento è possibile avviare Ubuntu solo in modalità di ripristino.

Dopo aver effettuato l'accesso (nella shell in modalità di ripristino) il messaggio di benvenuto dice "Benvenuto in Ubuntu 15.04" ma "la tua versione di Ubuntu non è più supportata" e "nuova versione '.04' disponibili" gli avvisi appaiono ancora.

Ho provato nuovamente a do-release-upgrade ma ho ricevuto il messaggio "nessun nuovo rilascio trovato".

Come posso terminare o rieseguire l'aggiornamento ??

Grazie

    
posta Eddie Lozada 08.08.2015 - 06:27

3 risposte

2

Hai già parzialmente installato 15.04. Non ha senso fare un do-release-upgrade in più, e naturalmente dirà "Nessuna nuova versione trovata".

Quello che devi fare è il seguente comando che installerà i pacchetti mancanti, assumendo che apt-get sia installato in primo luogo:

sudo apt-get update && sudo apt-get dist-upgrade
    
risposta data daltonfury42 08.08.2015 - 08:45
3

Questo ha funzionato per me (eseguendo questo dopo un riavvio) è iniziato dove l'aggiornamento è stato interrotto.

sudo dpkg --configure -a
    
risposta data JxAxMxIxN 28.06.2017 - 04:31
0

Finalmente, è risolto. Per coloro che hanno problemi identici o simili:

Nella shell in modalità di ripristino: sudo apt-get update && sudo apt-get dist-upgrade

Ci sono voluti un paio di minuti e dopo il riavvio è apparso il messaggio "Avvio della versione 219". Così ho seguito questo link :

% Bl0ck_qu0te%

Dopo il riavvio, ho ricevuto "Impossibile avviare il servizio utente [email protected]", quindi ho seguito questo thread :

sudo apt-get purge fglrx*

sudo update-alternatives --remove-all x86_64-linux-gnu_gl_conf

sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx

sudo apt-get install fglrx-updates*

E ora va tutto bene.

    
risposta data Eddie Lozada 08.08.2015 - 08:55

Leggi altre domande sui tag