Ubuntu 14.04 si blocca dopo il login

4

Sono nuovo di Ubuntu e ho avuto qualche problema nell'installare il desktop (il programma di installazione si è bloccato). Sono stato in grado di installare utilizzando il pacchetto di installazione di Ubuntu Server (64 bit) e aggiunto ubuntu-desktop e i driver nvidia appropriati per la mia scheda video GT240 in seguito utilizzando apt-get . All'avvio del sistema, viene visualizzata la richiesta di accesso Unity e posso accedere, ma la barra laterale e l'altro chrome dell'unità non vengono visualizzati (è solo lo sfondo del desktop). Se clicco con il tasto destro, posso visualizzare il menu contestuale appropriato per il desktop, ma non posso avviare un terminale usando Alt + T o altri mezzi per attivare la funzionalità. Posso usare Alt + Ctrl + F6 per passare alla riga di comando, dove mi viene richiesto di effettuare il login, e dopo aver eseguito startx posso ottenere l'intera Unity / X Window UX da visualizzare, completa di barra degli strumenti e di tutto ciò che è migliorato risoluzione, ecc.

Devo aggiungere che ho già aggiunto compiz e attivato il plugin Unity per queste istruzioni .

Ecco perché tutto sembra subito dopo aver digitato startx nell'interfaccia della riga di comando.

Le mie domande sono:

  1. come faccio a capire cosa sta succedendo con il login che impedisce il corretto caricamento del desktop? Ho già provato a reinstallare il desktop, i driver video, ecc. Ma sembra sempre che si blocchi subito dopo il login. Ho letto altri post simili a questo problema, ma nessuno di loro sembrava menzionare il fatto di poter avviare kickstart X dalla riga di comando e fare in modo che tutto andasse bene.

  2. come faccio a caricarlo direttamente nella modalità desktop standard in modo corretto senza doverlo aprire e digitare startx ogni volta che avvio?

Quando rispondi, tieni presente che sono totalmente nuovo e probabilmente necessiterò di istruzioni chiare e dettagliate per eliminare ciò che devo fare.

    
posta Keith Pepin 16.09.2014 - 04:57

1 risposta

1

Finalmente ho funzionato correttamente passando prima a un terminale usando CTRL + ALT + F2 e poi eseguendo la seguente serie di comandi:

sudo service lightdm stop
rm ~/.config/dconf/user
sudo service lightdm start

Il seguente articolo è il luogo in cui ho trovato questa risposta e viene fornita più dettagli con alcune altre cose che la gente potrebbe provare, ma è stata quest'ultima opzione che ha risolto il mio problema.

(aggiornamento alla 14.04) l'unità non viene caricata dopo l'accesso al profilo di amministrazione dopo l'aggiornamento

    
risposta data Keith Pepin 27.11.2014 - 04:35

Leggi altre domande sui tag