Come installare DraftSight su Ubuntu

4

Ho Ubuntu sul mio portatile. Ho scaricato DraftSight e ho provato ad installarlo tramite terminale usando questi comandi che ho trovato online:

sudo apt-get install ia32-libs libdirectfb-extra libxcb-render-util0
sudo dpkg --force-all -i ~/Downloads/draftSight.deb
sudo apt-get -f 

Ha detto che manca un pacchetto e si offre di sostituirlo con altri pacchetti che ho fatto. Ho trovato l'icona ma quando provo a eseguire Draft, viene visualizzato questo messaggio: "Impossibile caricare i moduli. L'applicazione verrà chiusa. Reinstallare l'applicazione." Quando provo a disinstallarlo, dice che non può essere fatto perché non è installato.

Non ho familiarità con Ubuntu, ho appena iniziato a usarlo. Qualcuno può dirmi come risolvere questo problema, ho bisogno di questo programma per le mie lezioni e non voglio rinunciare ad usare Ubuntu.

    
posta Luby Lou 29.10.2013 - 23:27

5 risposte

1

Anch'io ho avuto questo problema. Questo sembra risolverlo:

sudo apt-get install libcanberra-gtk-module:i386 libcanberra-gtk0:i386
    
risposta data Dubstar_04 23.12.2013 - 21:33
0

Prova gdebi, scaricherà le dipendenze mancanti:

sudo apt-get install gdebi

sudo gdebi ~/Downloads/draftSight.deb
    
risposta data animaletdesequia 30.10.2013 - 00:33
0

Devi modificare il file .deb

#!/bin/sh

## Fix a DraftSight Debian package to make it installable on a 64bit machine.

## Last known realease is http://dl-ak.solidworks.com/nonsecure/draftsight/V1R4.0/draftSight.deb

ORIGINAL=draftSight.deb
PACKAGE=fixed-$ORIGINAL

if ! test -f $ORIGINAL
then
echo "$ORIGINAL file does not exist."
PACKAGE=$(zenity –file-selection –filename=draftSight.deb –file-filter=deb)
fi

echo "Copying $ORIGINAL into $PACKAGE"
cp $ORIGINAL $PACKAGE || exit 5;

echo "Extracting control.tar.gz"
ar x $PACKAGE control.tar.gz || exit 5;

echo "Unpacking control.tar.gz into control directory"
mkdir --parents control || exit 5;
tar -zxf control.tar.gz --directory control || exit 5;
mv control.tar.gz control.tar.gz.orig

echo "Removing wrong dependency (xdg-utils)"
if sed -in-place -e "s/ xdg-utils,//" control/control
then
  echo "Repacking contents of ‘control’ directory into control.tar.gz"
  (cd control; tar --create --file ../control.tar *) || exit 5;
  gzip --best --no-name control.tar
  echo "Storing patched control.tar.gz back into $PACKAGE";
  ar r $PACKAGE control.tar.gz || exit 5;
  echo "Draftsight original package $ORIGINAL patched into $PACKAGE"
fi
    
risposta data WitchCraft 11.02.2014 - 22:04
0

Per 16.04 e Draftsight 2016:

Nel terminale cd /opt/dassault-systemes/DraftSight/Linux/ .

Avvia HelpGuide con ./HelpGuide e cerca gli errori di dipendenza.

apt-get le dipendenze mancanti.

Mi mancava libgstreamer0.10 e pacchetto plugin.

    
risposta data Jacob 10.04.2016 - 10:25
0

Provalo: sudo apt-get install libgstreamer0.10-0 libgstreamer-plugins-base0.10-0 sudo apt-get install gstreamer0.10-pulseaudio

    
risposta data Aleksandr Menshikov 03.05.2016 - 18:19

Leggi altre domande sui tag