Perché ottengo dipendenze non soddisfatte installando spotify su 12.10?

4

Ho seguito le istruzioni per installare spotify come su vari forum e amp; siti, praticamente gli stessi passi ovunque. Ma quando arrivo alla linea spotify dell'installazione, ecco cosa succede:

The following packages have unmet dependencies:
 spotify-client : Depends: libgconf2-4 but it is not installable
E: Unable to correct problems, you have held broken packages.

Che cos'è libgconf2-4 e come posso risolvere questo problema?

    
posta francesca 22.03.2013 - 01:02

2 risposte

1

Ho avuto lo stesso identico problema. Quello che non va è che Spotify non può funzionare senza il pacchetto libgconf2-4 . Questo perché Spotify dipende su quel pacchetto. Sarebbe come eseguire un'applicazione come Minecraft senza aver precedentemente installato il pacchetto libgconf2-4 . Puoi scaricare libgconf2-4 da qui .

Ottieni il pacchetto in base alla versione di Ubuntu che hai. Dopo aver installato libgconf2-4 , Spotify dovrebbe installarsi e puoi accedere alla tua musica!

    
risposta data 16trohrt 31.05.2013 - 00:20
0
  

Installazione di Spotify

Il primo passo è aprire Sorgenti software tramite Unity Dash:

Seleziona la scheda "Altro software" in Sorgenti software 1

Fai clic su "Aggiungi" 2 e incolla quanto segue nel campo di immissione della casella che appare:

  deb http://repository.spotify.com stable non-free

Fai clic su "Aggiungi fonte" per confermare la modifica, quindi chiudi le fonti software.

  

Aggiungi il tasto di riscontro di Spotify

Il prossimo passo è aggiungere la chiave del repository per verificare che i pacchetti installati da questo PPA siano da chi dicono.

Apri una nuova finestra di Terminale

Incolla quanto segue, quindi premi Invio / Invio:

 sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59

Questo è quello! Ora puoi installare Spotify tramite il Software Center di Ubuntu (dopo aver controllato prima gli aggiornamenti software) o eseguendo il seguente comando nella finestra Terminale:

 sudo apt-get update && sudo apt-get install spotify-client

Una volta installato, puoi avviare Spotify da Unity Dash.

Fonte: OMG Ubuntu

Un'anteprima dei laboratori segreti di Spotify

    
risposta data Qasim 16.05.2013 - 13:58

Leggi altre domande sui tag