Come posso ripristinare xserver-xorg-core e xserver-common? [duplicare]

4

Un recente aggiornamento di Xorg ha rotto il mio desktop, che ora assomiglia a questo:

In breve, lo sfondo del desktop non si sta aggiornando sul display secondario. (E se non c'è un display secondario, lo sfondo del display principale interrompe l'aggiornamento.)

Esaminando la cronologia, ho scoperto che ciò è accaduto subito dopo l'aggiornamento di due pacchetti:

  • xserver-xorg-core
  • xserver-common

Questi sono stati aggiornati a 1.9.0-0ubuntu7.3.

Vorrei eseguire il downgrade di questi pacchetti. Come faccio?

Ho controllato che entrambi hanno un'altra versione nel repository maverick:

xserver-xorg-core:
  Installed: 2:1.9.0-0ubuntu7.3
  Candidate: 2:1.9.0-0ubuntu7.3
  Version table:
 *** 2:1.9.0-0ubuntu7.3 0
        500 http://fi.archive.ubuntu.com/ubuntu/ maverick-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.9.0-0ubuntu7 0
        500 http://fi.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

Tuttavia, apt non mi permetterà di eseguirne il downgrade:

[email protected] ~ % sudo apt-get install xserver-common=2:1.9.0-0ubuntu7 xserver-xorg-core=2:1.9.0-0ubuntu7

The following packages have unmet dependencies:
 xserver-xorg-core : Depends: xserver-xorg but it is not going to be installed
E: Broken packages

E questo è il motivo:

[email protected] ~ % sudo apt-get install xserver-common=2:1.9.0-0ubuntu7 xserver-xorg-core=2:1.9.0-0ubuntu7 xserver-xorg-core

The following packages have unmet dependencies:
 xserver-xorg-core : Depends: xserver-common (>= 2:1.9.0-0ubuntu7.3) but 2:1.9.0-0ubuntu7 is to be installed
E: Broken packages

Sono fuori dalle opzioni qui?

    
posta Ville Sundberg 30.01.2011 - 11:34

2 risposte

1

Questo risultato è stato abbastanza semplice:

  • Cerca i pacchetti appropriati in Launchpad
  • Scarica i pacchetti
  • esegui sudo dpkg -i sui pacchetti

Tuttavia, questo non ha risolto il mio problema. Continuerò a cercare.

    
risposta data Ville Sundberg 30.01.2011 - 13:55
1

Synaptic è anche in grado di eseguire il downgrade dei pacchetti: fare clic con il pulsante destro del mouse sul pacchetto desiderato, selezionare "Force version" e selezionare una versione precedente. Quindi fare clic sul pulsante Applica.

    
risposta data papukaija 20.02.2011 - 22:15

Leggi altre domande sui tag