Lubuntu 14.04 Stanco della sospensione e ibernazione "power manager non autorizzato"

4

Sotto il post, l'ultima configurazione che ho usato, sembra funzionare bene.

Ho installato Lubuntu 14.04 sul mio netbook (aspiro uno ao-532h). Lo sto usando come un desktop con display esterno e dispositivi di input.

Dopo alcuni errori ho recentemente reinstallato Lubuntu (prima ho anche eliminato tutti i .* di file e directory nella mia home directory e formattato la partizione di root).

Uno di questi errori era l'impossibilità del sistema di passare automaticamente alla modalità di sospensione. Questo nonostante le impostazioni di xcfe4-power-manager siano impostate per farlo. Non ci sono stati problemi durante la sospensione manuale.

Dopo l'installazione, sembra che l'icona di impostazione di power manager xcfe4 non sia caricata all'avvio più. Nonostante questa modalità di sospensione sembra funzionare bene (dopo alcuni minuti non si utilizza il sistema, si sospende automaticamente). Pensavo che il tempo fosse impostato su xcfe4-power-manager (nonostante non fosse visibile).

Dopo aver installato alcune applicazioni (Lyx, netbeans con jdk ..) e cambiato le impostazioni del monitor (solo il vga esterno abilitato con il display del netbook spento) il problema descritto in precedenza è riapparso:

Il monitor entra in sospensione e poi si spegne correttamente. Ma aspettando i 15 minuti (non capisco perché non riesco a impostare un tempo per andare in modalità sospensione / ibernazione inferiore a 15 minuti) ** il sistema rimane acceso. Quando si disabilita lo screensaver viene visualizzato il messaggio "power manager non autorizzato". **

Qualche suggerimento?

Ho cercato informazioni su questo messaggio mongolfiera ("power manager non autorizzato") e ho apportato alcune modifiche (ma non ho risolto il problema) : Sono in grado di

1) Avvia xcfe4-power-manager e l'icona delle impostazioni all'avvio in questi     metodi (alternativi):  - passando alla modalità laptomop sì nelle preferenze- e gt; lxsession predefinite    App  - aggiunta di una riga nell'applicazione di avvio xcfe4-power-manager --no-daemon

2) Enabled Opzione di ibernazione che aggiunge un file con nome     %codice%     e contenuti:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Configurazione che funziona bene:

La mia configurazione:

Ho installato anche:

  • gnome-power-manager, ma dopo averlo disinstallato.
  • pacchetto xcfe4-power-manager-plugin

Ho attivato modalità di sospensione, con la descrizione del file della politica.

Nelle preferenze di sistema / disco / impostazione dispositivo: stand-by dopo 9:20 min **; ** apm on, 255

xcfe4-power-manager-settings prescrive:

  • in generale tab- & gt; "Controlla opzione schermata dello schermo" disabilitato ;
  • ac (uguale per batteria) tab- & gt; sleep pc dopo 15 min / schermo sleep 2 min disattiva 3 min
  • estesa modalità di sospensione del tab- & gt; pc Sospendi (funziona bene anche in ibernazione); monitorare sospendere; schermata di blocco se si avvia la modalità di sospensione o sospensione enabled

nelle preferenze

  • apps..lxsessions / autostart- & gt; power manager ** / screensaver / blocco schermo ** tutto abilitato
  • app..lxsessions / settings- & gt; modalità laptop
  • apps..lxsessions / core application- & gt; power manager: auto ; lock screen manager: blank ; screensaver: lxlock
posta mtt 03.08.2014 - 18:20

2 risposte

1

Sulla mia macchina, sono stato in grado di sospendere la macchina dopo inattività modificando il file /usr/share/polkit-1/actions/org.freedesktop.upower.policy/org.freedesktop.upower.policy e set

<defaults>
  <allow_inactive>yes</allow_inactive>
  <allow_active>yes</allow_active>
</defaults>

Spero che questo aiuti

    
risposta data tigerdog 13.10.2014 - 06:28
0

Thaddaeus Tintenfisch (thad-fisch) ha scritto nel 2015- 01-07 :

  

Questo problema è attivato dal light-locker che blocca la sessione dell'utente   (VT7) e inoltra l'utente alla schermata di sblocco (VT8). Si prega di leggere    il blog ufficiale per ulteriori informazioni su come bloccare lo schermo   funziona.

     

Il risultato di questa funzionalità è che la sessione utente diventa   inattivo mentre lo schermo è bloccato. Pertanto, il power manager è   non autorizzato ad eseguire determinate azioni più.

     

Le possibili soluzioni sono:

     
  • abilita il blocco tardivo (ritarda lo switch VT, abilitarlo tramite Impostazioni Light Locker & gt; Blocca automaticamente la sessione quando lo screensaver   è disattivato)
  •   
  • disabilita completamente il blocco automatico
  •   
  • cambia il criterio di uper secondo ( commento # 14 )
  •   

Disabilitare il light-locker nelle Impostazioni Light Locker abilita la modalità sleep, ma se la schermata di blocco del BIOS è troppo brutta, apri /usr/share/polkit-1/actions/org.freedesktop.upower.policy/org.freedesktop.upower.policy come root e imposta <allow_inactive>yes</allow_inactive> per consentire la sospensione e l'ibernazione mentre la sessione è bloccata.

    
risposta data Cees Timmerman 26.08.2015 - 22:09

Leggi altre domande sui tag