Errore AppArmor: "definizione VM non valida" dopo l'avvio di lxc sulla versione aggiornata di libvirt (1.2.12)

4

Sto provando ad avviare un LXC su una versione più recente di libvirtd ma non riesce a iniziare con il seguente errore:

$ virsh -c lxc: start textlxc
error: Failed to start domain testlxc
error: internal error: cannot load AppArmor profile 'libvirt-dfb2c573-05cb-4ca3-9e46-bea6cebf0f9f'

Messaggio di errore in /var/log/libvirt/libvirtd.log

2015-06-23 12:13:12.306+0000: 14141: error : virCommandWait:2532 : internal error: Child process (/usr/lib/libvirt/virt-aa-helper -p 0 -c -u libvirt-dfb2c573-05cb-4ca3-9e46-bea6cebf0f9f) unexpected exit status 1: virt-aa-helper: error: /proc/meminfo
virt-aa-helper: error: skipped restricted file
virt-aa-helper: error: invalid VM definition

2015-06-23 12:13:12.306+0000: 14141: error : AppArmorGenSecurityLabel:468 : internal error: cannot load AppArmor profile 'libvirt-dfb2c573-05cb-4ca3-9e46-bea6cebf0f9f'

Questo è il mio file testlxc.xml

<domain type='lxc'>
  <name>testlxc</name>
  <uuid>dfb2c573-05cb-4ca3-9e46-bea6cebf0f9f</uuid>
  <memory unit='KiB'>4048292</memory>
  <currentMemory unit='KiB'>4048292</currentMemory>
  <vcpu placement='static'>2</vcpu>
  <resource>
    <partition>/machine</partition>
  </resource>
  <os>
    <type arch='x86_64'>exe</type>
    <init>/sbin/init</init>
  </os>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/lib/libvirt/libvirt_lxc</emulator>
    <filesystem type='mount' accessmode='passthrough'>
      <source dir='/var/lib/libvirt/filesystems/testlxc'/>
      <target dir='/'/>
    </filesystem>
    <filesystem type='mount' accessmode='passthrough'>
      <source dir='/var/lib/libvirt/filesystems/testlxc-data'/>
      <target dir='/mnt/data'/>
    </filesystem>
    <filesystem type='mount' accessmode='passthrough'>
      <source dir='/var/run/testlxc/lxc'/>
      <target dir='/mnt/run'/>
    </filesystem>
    <filesystem type='mount' accessmode='passthrough'>
      <source dir='/proc/meminfo'/>
      <target dir='/proc/meminfo'/>
    </filesystem>
    <console type='pty' tty='/dev/pts/1'>
      <source path='/dev/pts/1'/>
      <target type='lxc' port='0'/>
      <alias name='console0'/>
    </console>
  </devices>
</domain>

La versione di Libvirt in esecuzione è la 1.2.12, avevo già eseguito con successo lxc sulla versione 1.2.2.

$ libvirtd --version
libvirtd (libvirt) 1.2.12
    
posta Bilal Baqar 23.06.2015 - 17:11

1 risposta

1

Ho rintracciato il problema alla convalida XML del dominio in virt-aa-helper utility. Questa è l'utility che dovrebbe generare profili apparmor su richiesta. Non è la struttura dell'XML che fallisce, ma l'errore riportato sembra indicare che questo è il caso. Una convalida logica all'interno della funzione virDomainDefParseXML in domain_conf.c è interrotta per i contenitori LXC.

Non ho familiarità con il codice di libvirt per modificare quest'area condivisa - potrei aver rotto qualcos'altro, ma la seguente patch sembra funzionare:

if (!(flags & VIR_DOMAIN_DEF_PARSE_SKIP_OSTYPE_CHECKS)) {
    /* If the logic here seems fairly arbitrary, that's because it is :)
     * This is duplicating how the code worked before
     * CapabilitiesDomainDataLookup was added. We can simplify this,
     * but it would take a bit of work because the test suite fails
     * in numerous minor ways. */
    bool use_virttype = ((def->os.arch == VIR_ARCH_NONE) ||
        !def->os.machine);
    virCapsDomainDataPtr capsdata = NULL;

da leggere

if (!(flags & VIR_DOMAIN_DEF_PARSE_SKIP_OSTYPE_CHECKS)) {
    /* If the logic here seems fairly arbitrary, that's because it is :)
     * This is duplicating how the code worked before
     * CapabilitiesDomainDataLookup was added. We can simplify this,
     * but it would take a bit of work because the test suite fails
     * in numerous minor ways. */
    bool use_virttype = (def->os.type != VIR_DOMAIN_OS_TYPE_EXE) &&
        ((def->os.arch == VIR_ARCH_NONE) ||
          !def->os.machine);
    virCapsDomainDataPtr capsdata = NULL;

Purtroppo non sono riuscito a trovare un modo per risolvere il problema senza ricompilare. Se si utilizza una macchina a 64 bit, è possibile scaricare i pacchetti che ho creato localmente da questo collegamento (scusate il mio account Microsoft).

Nota : per vedere se sei affetto da questo bug, inserisci quanto segue in un prompt dei comandi (copiato da questo forum posta ):

$ export VM=foo ; virsh -c lxc:// dumpxml $VM |\
   sudo /usr/lib/libvirt/virt-aa-helper -c \
   -u libvirt-'virsh -c lxc:// domuuid $VM'

Dove foo è il nome del contenitore lxc che fallisce. Se vedi l'output

virt-aa-helper: error: could not parse XML
virt-aa-helper: error: could not get VM definition

quindi probabilmente è lo stesso bug.

    
risposta data vhallac 31.10.2015 - 21:20

Leggi altre domande sui tag