apt-get non riesce ad aggiornare i pacchetti

4

Utilizzo il server Ubuntu 12.04:

[email protected]:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.5 LTS
Release:        12.04
Codename:       precise

Il mio problema è questo: quando vado ad aggiornare i pacchetti (in particolare cercando php5, ma succede per molti / la maggior parte / tutti) questo è ciò che ottengo:

[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 apache2-suexec-custom : Depends: apache2-bin but it is not installed
E: Unmet dependencies. Try using -f.


[email protected]:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libnet-xwhois-perl libtommath0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  apache2-bin
The following NEW packages will be installed:
  apache2-bin
0 upgraded, 1 newly installed, 0 to remove and 29 not upgraded.
1 not fully installed or removed.
Need to get 0 B/953 kB of archives.
After this operation, 3576 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 95668 files and directories currently installed.)
Unpacking apache2-bin (from .../apache2-bin_2.4.16-4+deb.sury.org~precise+4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/apache2-bin_2.4.16-4+deb.sury.org~precise+4_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man8/apache2.8.gz', which is also in package apache2.2-common 2.2.22-1ubuntu1.10
dpkg-deb (subprocess): subprocess data was killed by signal (Broken pipe)
dpkg-deb: error: subprocess <decompress> returned error exit status 2
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/apache2-bin_2.4.16-4+deb.sury.org~precise+4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Che cosa posso fare per risolvere questi errori? Mi piacerebbe davvero avere una versione PHP più recente di 5.3 , dal momento che ho più elementi che richiedono il minimo di PHP v5.4.

NOTA: non sto tentando di risolvere il problema delle impostazioni locali, sto provando a correggere l'errore dpkg. Questo server ha sempre avuto un problema locale ed è completamente separato. Ci dispiace, ma questo non è un duplicato.

Modifiche per il codice aggiunto:

[email protected]:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of apache2-suexec-custom:
 apache2-suexec-custom depends on apache2-bin; however:
  Package apache2-bin is not installed.
dpkg: error processing apache2-suexec-custom (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apache2-suexec-custom


Output di sudo apt-get install apache2 :

[email protected]:~$ sudo apt-get install apache2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apache2 : Depends: apache2-bin (= 2.4.16-4+deb.sury.org~precise+4) but it is not going to be installed
           Depends: apache2-data (= 2.4.16-4+deb.sury.org~precise+4) but it is not going to be installed
           Conflicts: apache2.2-bin but 2.2.22-1ubuntu1.10 is to be installed
           Conflicts: apache2.2-common but 2.2.22-1ubuntu1.10 is to be installed
 apache2-suexec-custom : Depends: apache2-bin but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


OK, ecco cosa ho appena scoperto. Le cose sembrano funzionare bene con apache2-suexec-custom rimosso. Ma ho ancora questo:

[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  apache2 libapache2-mod-php5 libjson0:i386 php-apc php-pear php5 php5-cgi php5-cli php5-common php5-curl php5-dev php5-fpm php5-gd php5-imagick php5-imap php5-intl
  php5-ldap php5-mcrypt php5-memcache php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.

[email protected]:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.

Quindi che cosa è con il 29 non aggiornato? Vado a curiosare e cerco la risposta in altre domande nel frattempo ...

SWEET !!! Vedi la risposta di DanielSmith-Chatbot per la mia soluzione ...

    
posta Daniel 26.11.2015 - 02:59

3 risposte

2

OK ecco qual è il problema:

C'era un pacchetto gravemente incasinato dal nome di apache2-suexec-custom che aveva bisogno e odiato lo stesso pacchetto. Rimuovilo e gli altri pacchetti ora sono in grado di dist-upgrade . Esegui sudo apt-get dist-upgrade ; sudo apt-get upgrade e tutto è aggiornato.

Grazie per il vostro aiuto (ish) ragazzi! Non una soluzione prevista, ma ha funzionato!

    
risposta data Daniel Smith - Chatbot 05.12.2015 - 03:43
0

Questo aiuto? :

  

sudo apt-get install --reinstall apache2 --fix-missing

o se questo non fosse sufficiente, prova a installare con package-manager di unity tutti i pacchetti riguardanti "lamp" come search-word, quindi vengono elencati tutti i pacchetti necessari.

Se sopra non è stato di aiuto, questo link dovrebbe contenere le risposte:

I seguenti pacchetti hanno dipendenze non soddisfatte (apache)

E c'è:

Come posso risolvere le dipendenze non soddisfatte dopo aver aggiunto un PPA?

    
risposta data dschinn1001 04.12.2015 - 23:44
-1

controlla le impostazioni locali sul server

Puoi vedere la soluzione in questo argomento: Come posso risolvere il problema della mia localizzazione?

    
risposta data Phan Văn Vũ 26.11.2015 - 05:07

Leggi altre domande sui tag