Apache2 Errore di sintassi, impossibile accedere a 000-default

4

Utilizzo Apache2 e Webmin con il mio Raspberry Pi. Dopo un riavvio e reinstallazioni, Apache non verrà avviato.

> sudo /etc/init.d/apache2 restart
apache2: Syntax error on line 268 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/000-default: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
failed!

Il file 000-default è lì e permessi non apribili per root-root. Il mio file apache2.conf ha questo aspetto (metà inferiore):

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel debug

# Include module configuration:
Include mods-enabled/*.load
Include mods-enabled/*.conf

# Include list of ports to listen on and which to use for name based vhosts
Include ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see the comments above for details.

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/
<VirtualHost *:80>
DocumentRoot /var/www
<Directory /var/www>
allow from all
Options +Indexes
</Directory>
ServerName IMASERVER
</VirtualHost>

Qualcuno sa qual è la causa di questo?

    
posta enrique2334 08.10.2012 - 07:52

1 risposta

1

In primo luogo, avere VirtualHost (s) all'interno del file di configurazione è una mossa sbagliata, (non sono nemmeno sicuro che sia possibile) l'intera idea di siti abilitati è di avere i tuoi VirtualHost in file diversi in quella cartella, e semplicemente usare

a2ensite default
a2dissite 000-default

Detto questo, puoi provare a rimuovere il blocco VirtualHost nel tuo file di configurazione e creare (o modificare) il file predefinito in siti abilitati. Assicurati di riavviare Apache.

Presumo che il file che hai pubblicato sia /<some-dir>/apache2/apache2.conf

Tuttavia, il file che hai postato sopra non assomiglia ai file di configurazione che ho visto per Apache. Non posso aiutarti su questo.

    
risposta data Erro 08.10.2012 - 08:19

Leggi altre domande sui tag