Come disabilitare IPv6 in Ubuntu 14.04?

115

Sto usando Ubuntu 14.04. E ho fatto quanto segue per disabilitare ipv6 .

Ho aperto /etc/sysctl.conf utilizzando gedit e incolliamo le seguenti righe alla fine di sysctl.conf .

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1 

Ma quando lo controllo usando il seguente comando,

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Sto ottenendo il risultato come '0' (cioè ancora abilitato). Per favore aiutami a disabilitare ipv6, così posso usare hadoop.

Ho seguito le istruzioni da questo link .

    
posta A J 29.03.2014 - 08:59

3 risposte

196

Per disabilitare ipv6, devi aprire /etc/sysctl.conf usando un qualsiasi editor di testo e inserisci le seguenti righe alla fine:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Se ipv6 non è ancora disabilitato, il problema è che sysctl.conf non è ancora attivato.

Per risolvere questo, apri un terminale ( Ctrl + Alt + T ) e scrivi il comando,

sudo sysctl -p

Lo vedrai nel terminale:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Dopodiché, se corri:

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Riporterà:

1

Se vedi 1 , ipv6 è stato disabilitato con successo.

    
risposta data A J 17.06.2014 - 12:04
15

Potresti voler disabilitarlo fin dall'inizio. A tal fine, apri /etc/default/grub con il tuo editor di testo preferito con accesso root (forse sudo vi /etc/default/grub .

In questo file, trova questa riga:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

e modificalo in:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"

Salva il file e aggiorna grub eseguendo:

sudo update-grub

=============================
Mint 19 e Ubuntu 18.04:

su Mint 19 sarebbe "xed admin: /// etc / default / grub" e forse su Ubuntu 18.04 "gedit admin: /// etc / default / grub" per ottenere un editor GUI per fare le modifiche a il file. Il resto dei passaggi sarà lo stesso.

    
risposta data Mostafa Ahangarha 05.05.2016 - 16:29
-2

Oltre alla risposta di Ross Rogers sopra, devi aggiungere:

sudo nano /etc/init/scip.conf

# description "Start sysctl at boot"

description "sysctl"

start on runlevel [2345]
stop on runlevel [016]

console log

respawn
respawn limit unlimited

exec /sbin/sysctl -p
    
risposta data scopa 07.07.2016 - 16:51

Leggi altre domande sui tag