ROS non si installerà su 14.04 (dipendenza dall'inferno)

4

Ho provato ad installare ROS su Ubuntu 14.04 usando questa guida .
Quando faccio sudo apt-get install ros-indigo-desktop-full ottengo il seguente errore di dipendenza che risulta in un incubo di dipendenze non appena provo a risolverli:

The following packages have unmet dependencies:
 ros-indigo-desktop-full : Depends: ros-indigo-desktop but it is not going to be installed
                       Depends: ros-indigo-perception but it is not going to be installed
                       Depends: ros-indigo-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.'

Che cosa sto facendo male qui?

    
posta bobo 20.11.2014 - 10:01

2 risposte

1

Ho avuto questo problema anche perché avevo installato alcuni pacchetti gazebo4 e gazebo5. Sfortunatamente, Indigo viene fornito solo con gazebo2 e non verrà installato se sono già presenti altri pacchetti gazebo.

Inoltre, da questa risposta , ho dovuto installare prima questo pacchetto:

sudo apt-get install libsdformat1

Dopodiché, ros-indigo-desktop-full ha installato bene per me il 14.04.

    
risposta data Cerin 04.05.2015 - 03:04
0

Ho provato con "aptitude" per risolvere il problema delle dipendenze. Sembra che alcune librerie debbano essere declassate.

    
risposta data VHMG 01.05.2015 - 05:38

Leggi altre domande sui tag