Clementine appare in due PPA. Come posso specificare quale usare?

4

Il pacchetto di clementine in 12.04 manca di supporto Spotify. Così ho aggiunto la clementina PPA in questo modo:

sudo add-apt-repository ppa:me-davidsansome/clementine
sudo apt-get update
sudo apt-get install clementine

Quindi ho installato in questo modo:

sudo apt-get install clementine=1.0.1~precise

Perché questa è la versione del PPA specifico per la clementina. Ma ora il gestore aggiornamenti vuole aggiornare la versione dall'archivio ubuntu perché è più recente.

Come posso dire di mantenere la clementina dal PPA della clementina, non il PPA di Ubuntu?

Mi rendo conto che domande simili sono state poste ma non esattamente questo, e non riesco a capirlo, quindi qualsiasi aiuto sarebbe apprezzato.

Grazie.

    
posta S Wilson 05.06.2012 - 17:24

2 risposte

1

Molto più utile del blocco sarebbe stato bloccare Clementine sul PPA. Questo farebbe esattamente quello che vuoi: assicurati che apt preferisca sempre la versione di Clementine presente nel PPA. Appuntare è fantastico se lo fai correttamente. link

    
risposta data Brandon 09.01.2013 - 16:00
0

Con Synaptic puoi "forzare" l'installazione di un pacchetto diverso da quello scelto da Synaptic. Effettua le seguenti operazioni:

  1. Fai clic su Ricarica o premi Ctrl + R per rendere Synaptic informato degli ultimi aggiornamenti.

  2. Seleziona il pacchetto. Scegli Forza versione dal menu Pacchetto.

  3. Seleziona la versione che desideri utilizzare. Per confermare la tua decisione, fai clic su Forza.

  4. Fai clic su Applica sulla barra degli strumenti o premi Ctrl + P. Viene visualizzata una finestra di dialogo con un riepilogo delle modifiche che verranno apportate al tuo sistema. Per confermare, premere Applica.

risposta data jasmines 05.06.2012 - 17:46

Leggi altre domande sui tag