Nagios che mostra l'errore "NOT FOUND"

4

Ho installato il pacchetto nagios nel mio sistema Ubuntu. Dopo aver aperto la pagina di configurazione localhost/nagios3 ho eseguito correttamente il login. Dopo di che, quando seleziono qualsiasi opzione dal menu di sinistra, viene visualizzato uno dei seguenti errori

The requested URL /cgi-bin/nagios3/extinfo.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/showlog.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/notifications.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/history.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/status.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/outages.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/statuswrl.cgi was not found on this server.
The requested URL /cgi-bin/nagios3/trends.cgi was not found on this server.

Apache/2.2.14 (Ubuntu) Server at 192.168.1.7 Port 80

Come risolvere questo problema?

    
posta surendar 13.06.2013 - 14:50

3 risposte

3

Verifica se il file di configurazione di Apache /etc/apache2/sites-available/nagios3.conf ,

/etc/apache2/conf.d/nagios3.conf or similar ha voci "ScriptAlias" come quella

di seguito (assicurati di avere i percorsi corretti del file system):

  ScriptAlias /cgi-bin/nagios3 /usr/lib/cgi-bin/nagios3
  ScriptAlias /nagios3/cgi-bin /usr/lib/cgi-bin/nagios3
    
risposta data Steve Baroti 05.03.2014 - 22:55
0

Controlla anche quali moduli apache hai abilitato - puoi vederli con ls -la /etc/apache2/mods-enabled . Avete bisogno dei moduli php e cgi abilitati. Hai bisogno di php installato e potresti aver bisogno di cambiare il modulo mpm che hai abilitato. Su Ubuntu 16.04, ecco i comandi che dovevo eseguire per superare questo errore:

sudo a2dismod mpm_event
sudo a2enmod mpm_prefork
sudo a2enmod cgi
sudo apt-get install libapache2-mod-php
sudo a2enmod php7.0
sudo service apache2 restart

I moduli disponibili sono elencati in /etc/apache2/mods-available .

    
risposta data Alicia 09.05.2017 - 04:33
-2

Ho trovato nella stessa situazione che mancavano alcune dipendenze poiché le esercitazioni non le includevano. Ne ho trovato uno che ha risolto il problema. Dovresti controllare se questo installa più di quello che hai -

apt-get install build-essential php5-gd wget libgd2-xpm-dev libapache2-mod-php5 apache2-utils daemon unzip
    
risposta data sharpy1064 05.12.2015 - 23:50

Leggi altre domande sui tag