Pacchetto interrotto quando si tenta di installare libminiupnpc-dev

4

Non sono sicuro di come risolvere i seguenti errori di pacchetto non funzionanti. Ho installato libminiupnpc8 da un PPA (1.6-precise2) e quando voglio installare libminiupnpc-dev, vuole installare libminiupnpc8 (1.6-3ubuntu1) dal repository standard. Qual è il modo migliore per risolvere questo? Posso impostare un precedente nell'elenco dei repository in modo che prenda quello di Ubuntu prima di quello privato?

$ sudo apt-get install libminiupnpc-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libminiupnpc-dev : Depends: libminiupnpc8 (= 1.6-3ubuntu1) but 1.6-precise2 is to be installed
E: Unable to correct problems, you have held broken packages.
    
posta Jeff 28.05.2013 - 19:59

1 risposta

1

La soluzione migliore è, se quei pacchetti necessari sono nel Repository ufficiale di Ubuntu, rimuovi quel PPA e installa i pacchetti necessari.

Sembra che libminiupnpc-dev debba essere installato dal repository principale, non dal PPA. Se vuoi usare quel repository in qualche modo, devi fare appuntare . Ciò significa che è necessario ottenere una posizione più alta per quel PPA in fase di installazione. Per farlo esegui questo:

gksudo gedit /etc/apt/preferences

Quindi aggiungi le seguenti righe a Gedit e salva:

Package: libminiupnpc-dev
Pin: release o=Ubuntu
Pin-Priority: 100

Package: libminiupnpc-dev
Pin: release o=LP-PPA-<ppa name>
Pin-Priority: 200

** Sostituisci & lt; nome ppa & gt; con quel nome PPA (senza frase ppa: )

    
risposta data user224082 18.11.2013 - 07:03

Leggi altre domande sui tag