Come posso essere sicuro che il pinning con apt-get sia compatibile con i pacchetti virtuali?

4

Per consentire a php5.2 di essere utilizzato su lucido, ho creato un ppa ( ppa: txwikinger / php5. 2 ) e crea diversi pacchetti php5.2 lì. Per preferire quei pacchetti ho dato istruzioni per appuntarli. Tuttavia, i pacchetti php5-mcrypt e php5-imap non si caricano correttamente a causa della dipendenza da phpapi, anche phpapi è fornito da php5-cgi, php5-cli che sono disponibili. Qual è il problema?

    
posta txwikinger 05.09.2010 - 00:46

1 risposta

1

Ho trovato il problema. Ho fatto un errore con le condizioni di pinning.

Modifica:

La versione del pinning non corrispondeva a ciò che si poteva trovare o mancava per il pacchetto a seconda del pacchetto virtuale.

    
risposta data txwikinger 05.09.2010 - 04:12

Leggi altre domande sui tag