Kernel panic dopo l'aggiornamento a 4.4.0-108-generic

33

Oggi ho ottenuto quello che presumo fosse l'aggiornamento che dovrebbe occuparsi di Spectre e Meltdown. Non è andata molto bene. Cosa faccio ora? Vedi la foto sullo schermo.

Non riesco ad avviare il kernel 4.4.0-108-generic a causa di un panico del kernel. Sto utilizzando la versione 16.04 su una CPU Intel Core i5-4670K a 3.40GHz × 4.

    
posta fregger 10.01.2018 - 00:47

5 risposte

33

Non installare 4.4.0-108-generico su Xenial! È interrompe l'avvio / riavvio / arresto / sospende la funzionalità !

Installa 4.4.0-109-generic ( vedi USN-3522-3 per dettagli) !

Riavvia fino all'ultimo kernel funzionante e rimuovi 4.4.0-108-generic:

  1. Premi Shift tra UEFI / BIOS e login-screen per inserire GRUB
  2. In GRUB seleziona Advanced options for Ubuntu e seleziona Ubuntu, with Linux 4.4.0-xxx-generic (dove xxx & lt; 108)
  3. Accedi al sistema e rimuovi questo bug 4.4.0-108-generic e installa 4.4.0-104-generic invece.

    sudo apt-get purge linux-headers-4.4.0-108 linux-headers-4.4.0-108-generic \
    linux-image-4.4.0-108-generic linux-image-extra-4.4.0-108-generic \
    linux-tools-4.4.0-108 linux-tools-4.4.0-108-generic
    sudo apt-get autoremove
    sudo apt-get install linux-headers-4.4.0-104 linux-headers-4.4.0-104-generic \
    linux-image-4.4.0-104-generic linux-image-extra-4.4.0-104-generic \
    linux-tools-4.4.0-104 linux-tools-4.4.0-104-generic
    

A partire dal 2018-01-10 18:00 UTC, il kernel 4.4.0-109-generico sembra essere distribuito sui mirror.

Ma se lo desideri puoi selezionare Server principale ( link ).
Puoi passare da software-properties-gtk / software-properties-kde .

Puoi installare 4.4.0-109-generic con i seguenti comandi:

sudo apt-get update
sudo apt-get install linux-headers-4.4.0-109 linux-headers-4.4.0-109-generic \
linux-headers-generic linux-image-4.4.0-109-generic \
linux-image-extra-4.4.0-109-generic linux-image-generic \
linux-tools-4.4.0-109 linux-tools-4.4.0-109-generic linux-tools-generic
    
risposta data N0rbert 10.01.2018 - 13:14
6

Nel menu di avvio scegli advanced options for ubuntu .

Puoi avviare da un kernel precedente (che è ancora installato) lì.

    
risposta data Erik Lamers 10.01.2018 - 11:21
1

Non riesco ad avviarlo usando 109 o 108 ubutnu VM su win 7 x64

vedi: link

my domanda

ho dovuto avviare utilizzando 104

    
risposta data rajeev 15.01.2018 - 22:03
0

Questo ha risolto il problema per me:

  1. Usando il menu di avvio di grub, avvia la versione precedente del kernel.
  2. Installa anche il kernel più recente

sudo apt install linux-generic-hwe-16.04-edge

Aggiornamento: sembra un problema con la versione 4.4.0.108 risolto con la versione 4.4.0.109 rilasciata proprio ora.

    
risposta data Yngvi Hrafn Pétursson 10.01.2018 - 13:20
-1

È possibile installare l'ultima patch con successo se si avvia con un kernel più vecchio (sono tornato indietro di circa tre rilasci) quindi eseguire Ubuntu con tutti gli strumenti avanzati di "pulizia del sistema" di Ubuntu incluso fsck. Apparentemente c'è qualcosa nelle versioni precedenti che deve essere "corretto" prima che la patch possa essere installata con successo.

    
risposta data Bill Wilken 11.01.2018 - 13:51

Leggi altre domande sui tag