Non so come rimuovere pacchetti da aggiornare dalla 14.04 alla 16.04

5

Ho cercato di aggiornare dal 14.04 al 16.04 per alcune settimane senza successo. Come molti altri (ad esempio, qui ), ricevo un messaggio di errore che dice che Ubuntu" non può calcolare l'aggiornamento ". Ho provato a ispezionare /var/log/dist-upgrade/apt.log per scoprire quali pacchetti stavano causando il problema e ho ottenuto un elenco di circa 800 pacchetti danneggiati :

Broken dpkg:amd64 Breaks on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.19 > ( httpd ) (< 5.6.4+dfsg-3~)
Broken perl-base:amd64 Breaks on perl-modules [ amd64 ] < 5.18.2-2ubuntu1.1 > ( perl ) (< 5.22.1~)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-1ubuntu1~14.04.4 > ( python ) (< 3.4.4-2)
Broken libgnutls30:amd64 Conflicts on libnettle4 [ amd64 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken libgnutls30:amd64 Conflicts on libnettle4 [ i386 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken systemd:amd64 Conflicts on systemd-services [ amd64 ] < 204-5ubuntu20.19 > ( admin )
Broken systemd:amd64 Conflicts on systemd-services [ i386 ] < none > ( none )
Broken texlive-binaries:amd64 Breaks on luatex [ amd64 ] < 0.76.0-3ubuntu1 > ( tex ) (< 2014)
Broken libopencv-core2.4v5:amd64 Conflicts on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )
Broken gnome-control-center:amd64 Breaks on libgnome-control-center1 [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( libs )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-glamoregl [ amd64 ] < 0.6.0+git1603170630.347ef4~gd~t > ( x11 )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting [ amd64 ] < 0.8.1-1build1 > ( x11 )
Broken unity-control-center-faces:amd64 Conflicts on gnome-control-center-shared-data [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( gnome )
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-windows-live [ amd64 ] < 0.11+14.04.20140409.1-0ubuntu2 > ( gnome )
Broken ghc-doc:amd64 Breaks on libghc-transformers-doc [ amd64 ] < 0.3.0.0-5 > ( doc ) (< 0.3.0.0-6)
Broken libasprintf0v5:amd64 Breaks on libasprintf0c2 [ amd64 ] < 0.18.3.1-1ubuntu3 > ( libs )
Broken libopencv-imgproc2.4v5:amd64 Conflicts on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )

L'elenco potrebbe continuare all'infinito, ma potrebbe già dare un'idea di cosa sta succedendo. Ad ogni modo, ho archiviato un rapporto sui bug sul tracker di Ubuntu, ed è stato detto che il problema era probabilmente che ho installato pacchetti PPA che erano incompatibili con la nuova versione. Mi hanno suggerito di rimuovere questi pacchetti con ppa-purge , in particolare da oibaf PPA:

sudo ppa-purge oibaf

Tuttavia, ho ricevuto un errore:

Updating packages lists
PPA to be removed: oibaf ppa
Warning:  Could not find package list for PPA: oibaf ppa

Qualche indizio su come risolvere questo problema?

    
posta Arthur Azevedo De Amorim 01.10.2016 - 03:38

0 risposte

Leggi altre domande sui tag