I moduli ZFS non vengono caricati dopo l'aggiornamento del kernel

4

Quindi ho eseguito ZFS alla 14.04 per poco più di un anno e finora tutto è stato eseguito e aggiornato perfettamente.

Oggi dopo apt-get update vedo che so avere il kernel 4.4.0-59-generic (aggiornato da 3.19.0-78-generic). Ricordo che ci fu un lungo ritardo durante l'aggiornamento ma alla fine tutto apparve bene. Ho fatto un riavvio e ho lasciato la casa per qualche ora. Ora che ho effettuato il login, vedo che manca il mio pool zfs.

Quindi eseguo il comando zfs list e ricevo il messaggio "I moduli ZFS non sono caricati. Prova a eseguire '/ sbin / modprobe zfs' ". Così provo, stesso messaggio "i moduli ZFS non sono caricati".

Quindi ecco la mia domanda: dovrei provare a tornare al kernel precedente o dovrei semplicemente reinstallare i moduli zfs? Non voglio fare la mossa sbagliata perché temo di perdere il mio pool di 4,5 TB.

Qualsiasi suggerimento sarebbe molto apprezzato.

    
posta cms 11.01.2017 - 02:23

2 risposte

0

Apparentemente la versione di ZFS disponibile nei repository di Ubuntu non viene compilata con il kernel più recente, il che mi sembra una sfortunata svista. Fino a quando ZFS non sarà aggiornato alla versione 0.6.5.8 o la patch sarà backport, non funzionerà con questo kernel, e dovrai continuare a farne il boot più vecchio.

Fonte: link

Tieni presente che puoi modificare la configurazione di GRUB per salvare il kernel da cui hai eseguito l'ultimo avvio e avviare sempre da quello fino a quando non lo dici diversamente.

EDIT: In realtà sono in data 16.04, ma ricevo lo stesso errore di quella segnalazione di bug, quindi presumibilmente questo problema riguarda entrambe le versioni.

    
risposta data Ryan Thompson 12.01.2017 - 01:19
0

Ho riscontrato un problema durante l'utilizzo di mintupgrade da 17.3 - & gt; 18 (fidato - & gt; xenial), durante il processo di aggiornamento un pacchetto con cui avevo fatto confusione causava un parziale errore dell'aggiornamento, quindi quando si aggiorna dal kernel 3.X a 4.4.0-81-generico non è stato ricostruito correttamente tutto, mi ci è voluto un po 'per capire perché lo zfspool aveva uno status di online e sembrava buono ma non si presentava in df e non funzionava nonostante fosse montato in un posto che esisteva ancora, ho dovuto chiedere a dpkg di ricostruirli per 4.4.0:

sudo dpkg-reconfigure spl-dkms
sudo dpkg-reconfigure zfs-dkms
sudo zpool import zfspoolname
    
risposta data heyda 21.06.2017 - 21:53

Leggi altre domande sui tag