Wireless continua a disabilitare o rimane disconnesso (Realtek RTL8191SEvB)

4

Ho una scheda wireless Realtek RTL8191SEvB su Ubuntu 10.10:

$ lspci -v | grep Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

Quando carico il suo driver , secondo il Network Manager qualche volta lampeggia con un elenco di reti disponibili ma continua a disabilitarsi o rimane disconnessa. Quindi, non riesco a collegarmi a nessuna rete wi-fi (il che si traduce in frustrazione).

Il driver è caricato:

$ lsmod

Module                  Size  Used by
r8192se_pci           509932  0 

Sembra normale:

$ sudo lshw -C network

*-network               
     description: Wireless interface
     product: RTL8191SEvB Wireless LAN Controller
     vendor: Realtek Semiconductor Co., Ltd.
     physical id: 0
     bus info: [email protected]:03:00.0
     logical name: wlan0
     version: 10
     serial: 1c:65:9d:60:c7:7a
     width: 32 bits
     clock: 33MHz
     capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
     configuration: broadcast=yes driver=rtl819xSE driverversion=0019.1207.2010 firmware=63 latency=0 link=no multicast=yes wireless=802.11bgn
     resources: irq:17 ioport:2000(size=256) memory:f0500000-f0503fff

Configurato:

$ sudo iwconfig wlan0 

wlan0     802.11bgn  Nickname:"rtl8191SEVA2"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Bit Rate:130 Mb/s   
          Retry:on   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=10/100  Signal level=0 dBm  Noise level=-100 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Non bloccato:

$ rfkill list all

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: yes

Tuttavia qualcosa sta accadendo con esso:

$ dmesg

[ 6485.948668] InitializeAdapter8190(): ==++==> Turn off RF for RfOffReason(1073741824) ----------
[ 6486.062666] rtl8192_SetWirelessMode(), wireless_mode:10, bEnableHT = 1
[ 6486.062671] InitializeAdapter8192SE(): Set MRC settings on as default!!
[ 6486.062675] HW_VAR_MRC: Turn on 1T1R MRC!
[ 6486.064091] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6486.248761] rtl8192_SetWirelessMode(), wireless_mode:10, bEnableHT = 1
[ 6486.248771] InitializeAdapter8192SE(): Set MRC settings on as default!!
[ 6486.248776] HW_VAR_MRC: Turn on 1T1R MRC!
[ 6486.580083] GPIOChangeRF  - HW Radio OFF
[ 6486.610085] ============>sync_scan_hurryup out
[ 6486.623814] ================>r8192_wx_set_scan(): hwradio off
[ 6486.830484] =========>r8192_wx_set_essid():hw radio off,or Rf state is eRfOff, return

Quindi qualcuno sa dove potrebbe essere il problema?

    
posta Jindřich Mynarz 14.02.2011 - 21:34

1 risposta

1

Nei forum di Ubuntu raccomandano di scaricare il driver da Realtek ad es. link

    
risposta data Bernard Decock 14.02.2011 - 21:54

Leggi altre domande sui tag