Come disattivare i tasti di scelta F1 e F10 in gnome-terminal?

115

Come posso disattivare i collegamenti dei tasti F1 (aiuto) e F10 (menu delle notifiche)?

Per prima cosa ho bisogno di screen utility e second to exit mc in console.

Non ci sono associazioni di tasti simili nelle impostazioni di sistema Tasti di scelta rapida .

    
posta Marko Kevac 27.04.2011 - 15:55
fonte

14 risposte

106

11.04

Disabilitazione del collegamento F1

  1. In un terminale di gnome apri Modifica ➜ Tasti di scelta rapida .

  2. Scorri verso il basso fino alla scorciatoia Aiuto / Contenuti , fai clic su "F1" e premi Backspace :

Disabilitazione della scorciatoia F10

  1. Installa compizconfig-settings-manager pacchetto.

  2. Apri CompizConfig Settings Manager .

    • Premi Super per aprire il Dash, digita "Compiz" e premi Invio .
  3. Digita "unity" nella voce Filter e seleziona il Plugin Unity di Ubuntu .

  4. Fai clic sul pulsante a destra di Chiave per aprire il primo menu del pannello e deseleziona la casella di controllo Abilitata .

  5. Che disabilita la scorciatoia globale F10 , ora disabilita la scorciatoia F10 di gnome-terminal:

    • In un terminale di gnome apri Tasti di scelta rapida ( Modifica ➜ Scorciatoie da tastiera) e
      deselezionare Abilita il tasto di scelta rapida del menu (F10 per impostazione predefinita)

  6. F10 è mappato a menubar_accel da qualcosa in Ubuntu. Gnome? Metacity? Non sei sicuro di quale sia la cosa esatta che lo ruba, ma la chiave non arriva ad Eclipse.

    • Esegui gconf-editor, vai a / desktop / gnome / interface quindi scorri fino a menubar_accel ed elimina il valore F10. [Sottratto da qui]
risposta data Isaiah 23.06.2011 - 20:52
fonte
44

Disattiva F10 in gnome-terminal in 12.04

Digita questo nella console:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Quindi chiudi tutte le sessioni del terminale. Ora dovrebbe funzionare come dovrebbe (in mc per esempio).

risposta data Paweł Gościcki 30.04.2012 - 21:25
fonte
23

inizia gconf-editor e segui /apps/gnome-terminal/keybindings/help

Descrizione:

"Tasto di scelta rapida da tastiera per avviare la guida. Espresso come una stringa nello stesso formato utilizzato per i file di risorse GTK +. Se si imposta l'opzione sulla stringa speciale" disabilitata ", non ci sarà alcuna scelta rapida da tastiera per questa azione."

    
risposta data Rinzwind 21.08.2011 - 22:28
fonte
7

Sono nuovo di Linux e questa chiave F10 mi fa impazzire. Tutti i trucchi precedenti non hanno funzionato, ma ho trovato una soluzione (per Ubuntu 11.10 con Gnome 3 classic desktop). In un terminale, immettere il seguente comando:

gsettings set org.gnome.desktop.interface menubar-accel ""

Con dconf-editor si può scoprire che l'F10 è davvero sparito. Nota che questo tipo di trucchi sembra essere molto dipendente dalla versione di Gnome / Ubuntu.

    
risposta data gast128 29.11.2011 - 20:34
fonte
4

Per uscire da mc (con il tasto F10). Disabilita "Chiave per aprire il primo menu del pannello" in unity compiz plug-in (ccsm)

    
risposta data kholis 29.04.2011 - 12:33
fonte
4

@kholis è corretto per disabilitare F10 in Unity, ma se sei un newb come me, hai bisogno di un po 'più di informazioni per farlo funzionare.

Se non è già installato, installa compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Avvia il gestore delle impostazioni appena installato e filtra per "unity"

Modifica "Chiave per aprire il primo menu del pannello" per disattivarlo o cambiarlo su un altro tasto.

Non ho ancora trovato un modo per cambiare F1.

risposta data Ryan Sorensen 30.04.2011 - 19:36
fonte
3

L'istruzione al link (citata sotto) funziona anche su Ubuntu 11.04. (Sembra disabilitare F1 sia nel desktop che nel terminale, cioè F1 non invia una sequenza ansi alla shell nel terminale, se questo è ciò che l'OP voleva).

  
  1. Vai a Sistema - Preferenze - Scelte rapide da tastiera
  2.   
  3. Crea una nuova scorciatoia. Chiamalo "fai niente" e scrivi "falso"   (senza virgolette) nel campo "comando". Spingere ok.
  4.   
  5. Scorrere fino alla fine dell'elenco e trovare il nuovo comando. Clic   in "Disabled", a destra, e premi F1.
  6.   
    
risposta data David Andersson 22.08.2011 - 04:12
fonte
3

Puoi disabilitarlo facilmente usando CCSM (Fai clic per installarlo se non lo hai installato ).

Quindi vai a Desktop - & gt; Ubuntu Unity Plugin - & gt; Chiave per aprire il primo menu del pannello e disattivarlo o modificarlo con un'altra scorciatoia da tastiera.

Nota : sembra che questo metodo non funzioni in Unity2D.

    
risposta data Binarylife 27.10.2011 - 00:03
fonte
2

Questo è un suggerimento per gli utenti di Thnkpad, in particolare T60. Rimappa il tasto F1 per uscire. Questo elimina il fastidioso popup di aiuto del terminale quando colpisci F1. Lo fai spesso per il divertente posizionamento dell'ESC sui T60.

    
risposta data ncmathsadist 03.12.2011 - 18:42
fonte
1

Se vuoi solo cambiarlo in Terminale Gnome puoi fare clic su Modifica & gt; Scorciatoie da tastiera nel Terminale.

    
risposta data Jeremy Bicha 30.04.2011 - 20:37
fonte
1

Raccomando di usare F1 come scorciatoia per qualcos'altro. Gestisco Tilda, un terminale da riga di comando in stile terremoto, e il collegamento predefinito è F1. Sostituisce la Guida, quindi non ho mai aiutato l'avvio quando ho colpito F1. Anche se Tilda non ti piace molto, colpire nuovamente F1 per nasconderlo è molto meno noioso della chiusura di Help dopo averla accidentalmente lanciata.

    
risposta data titaniumtux 03.12.2011 - 20:23
fonte
1

12.04

F1 non sembra fare nulla fuori dalla scatola in 12.04
F10 sembra simulare un clic con il tasto destro del mouse

Quindi, in risposta alle specifiche della domanda, non è necessario disabilitare l'aiuto e le notifiche.

Puoi ancora associarli a qualcos'altro come questo:
La mappatura dei tasti di scelta rapida in 12.04 viene eseguita semplicemente tramite il widget Tastiera.

Nella tastiera di ricerca di Unity launcher.

Nella finestra che si apre seleziona la scheda scorciatoie e scorciatoie personalizzate.
Fai clic sul segno più per aggiungere una nuova scorciatoia.

Assegnagli un nome a qualsiasi cosa corrisponda alla funzionalità che stai assegnando.
Immettere il comando che si desidera eseguire nel comando.

Sul lato destro della finestra fai clic su dove dice disabilitato. Questo dovrebbe passare a New Accelerator.

Ora basta premere F10 .
L'acceleratore per scorciatoie personalizzate che hai definito sostituisce il comportamento di simulazione del tasto destro. Puoi impostare questo comando su echo 'nope' > /dev/null se vuoi che il tuo F10 non faccia nulla.

    
risposta data RobotHumans 02.04.2012 - 19:50
fonte
1

12.04 Senza Unity - Disabilita il comportamento F1 e F11

Ho installato Ubuntu 12.04 / 64 e ho completamente rimosso Unity da esso seguendo queste indicazioni. . Molti degli strumenti che modificano il comportamento di Unity, quindi, non funzionano. In particolare, CCSM non "vede" più le scorciatoie da tastiera.

Ho scoperto che il metodo che utilizzava Modifica- e gt; Tasti di scelta rapida nella finestra del terminale non funzionava. Dopo un po 'di gioco ho scoperto che guardando più in basso nella finestra Tasti di scelta rapida nella sezione Tasti di scelta rapida , F1 e F11 erano ancora definiti nelle rispettive scorciatoie.

Per risolvere il problema,

  1. Fai clic su "F11" nel campo a destra della linea che definisce F11 come a schermo intero. Il testo cambierà in "Nuovo acceleratore ...".

  2. Digitare qualche altra sequenza di tasti meno discutibile (come alt-F11) e quella combinazione di tasti sostituirà la scorciatoia. Se qualcuno sa come digitare "niente", faccelo sapere.

  3. Ripeti per il tasto F1.

risposta data Wes Miller 20.11.2013 - 17:33
fonte
0

Ctrl + F1 non funziona neanche. La soluzione è la stessa di Shift + F10. Non dimenticare il punto e virgola come separatore!

Inserisci questo in ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
risposta data egmont 16.03.2014 - 12:46
fonte

Leggi altre domande sui tag