Fastidioso sfarfallio in 16.04 LTS - Chrome

194

Ho aggiornato da 4.4.0 a 4.4.8 e poi 4.5.2 su Ubuntu 16.04 LTS a 64-bit, e sta ancora accadendo.

Alla 4.5.2 è ancora più frequente, e principalmente in Chrome (non ho ancora provato Firefox o Opera). Ogni volta che apro una nuova pagina web. Un modo per sistemarlo, o è un bug?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Saluti.

    
posta Mookey 03.05.2016 - 08:31

11 risposte

185

Dopo alcune ricerche, ho trovato una soluzione a questo problema. Funziona ora per me.

Ho disabilitato l'accelerazione hardware per il mio browser da

Settings > Advance Settings > System > uncheck the hardware acceleration

Spero che funzioni sulla tua macchina.

Sto utilizzando google-chrome-stable Version 50.0.2661.94 (64-bit) su Ubuntu 16.04

----- EDIT ----

Se si incontra scorrimento a scorrimento e rottura dello schermo. Fai come suggerito da Amos Folarin nel commento qui sotto:

Vai a: chrome://flags/#smooth-scrolling e Abilita.

    
risposta data sgiri 05.05.2016 - 19:54
158

Ho avuto lo stesso problema, l'impostazione della rasterizzazione della GPU su "Forza abilitata per tutti i livelli" sembra essere finalmente funzionante:

    
risposta data Gondy 08.08.2016 - 09:52
38

Apri un terminale e inserisci questo comando:

sudo nano /usr/share/applications/chromium-browser.desktop

e scorri verso il basso fino a raggiungere questa linea:

Exec= chromium-browser

Quindi aggiungi questi due parametri

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Premere Ctrl + O per salvare e Ctrl + X per uscire.

Quindi inserisci questo comando:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

e aggiungi queste linee

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Premi Ctrl + O quindi Ctrl + X.

Apri Chromium e scrivi nella barra degli indirizzi: chrome://flags/ e inserisci.

  • Attiva zero-copy
  • Abilita Sostituisci elenco di rendering del software
  • Abilita la visualizzazione della tela di lista 2D

Infine apri le impostazioni di Chrome e fai clic su:

  • Utilizza l'accelerazione hardware quando disponibile
risposta data zafer 27.07.2016 - 10:10
37

L'ho risolto come segue:

sudo apt-get purge xserver-xorg-video-intel

quindi riavviare. Questo perché i driver Intel sono passati alla modalità. Per maggiori informazioni vedi questo commento nella discussione del bug di Chromium .

    
risposta data ComBin 19.08.2016 - 16:25
24

Nessuna di queste risposte sembrava aiutarmi. Quello che ho fatto è che sembra averlo risolto (il mio riferimento era il sito link che tremolava come CRAZY e ora funziona senza intoppi) è questo:

1.- Navigato a chrome://gpu/ . Questo è quello che ha mostrato:

2.- Ho provato a risolvere i problemi uno per uno. Nel mio caso, l'abilitazione di questi flag ha corretto alcuni di essi: GPU rasterization , Override software rendering list . Quindi ha mostrato in questo modo:

3.- Ho modificato il launcher desktop e aggiunto i parametri --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers .

4.- Dopodiché, non vengono più rilevati problemi, tutto viene visualizzato come "accelerato hardware" e, cosa più importante, non c'è più sfarfallio:

Se aggiungi i parametri al programma di avvio per primo, l'elenco dei problemi dovrebbe essere più breve e probabilmente sarà più facile capire quali flag ti aiuteranno con i problemi che hai lasciato.

    
risposta data Nahuel 14.09.2016 - 14:29
7

Con Chrome versione 51.0.2704.103 (64-bit) i flag

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

non funziona più.

Il modo migliore che possiamo fare è tornare a Chrome 50 (Versione 50.0.2661.86 (64-bit)), ecco un'istruzione su come puoi fare un passo indietro: come faccio a eseguire il downgrade di google chrome?

È importante mettere pressione su Google per risolvere questo problema, votare per il bug in Chromium e nella pagina del prodotto di Google:

link

link

    
risposta data user157697 19.06.2016 - 10:02
5
chrome://flags/ > GPU rasterization > Enable,

Questo finalmente ha funzionato per me! Trovato in fondo a questo modulo di Google! link

    
risposta data Chris Lane Jones 16.10.2016 - 22:44
4

Penso di aver trovato la soluzione:

flags --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffer e anche enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
    
risposta data Hector 07.07.2016 - 17:14
2

Prova a caricare con alcune opzioni della GPU disabilitate:

- disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffer

Dopo aver provato, puoi anche giocare con alcune delle impostazioni di rendering in about: // flags e vedere se qualcosa aiuta, ma la maggior parte dei miei sfarfallio di rendering sono stati risolti dai due flag della riga di comando. Se si dispone di un file .desktop di avvio, aggiungere tali flag all'inizio della voce Exec prima di '% U'. Puoi anche aggiungerli alle altre voci di Exec per far applicare i flag a tutte le modalità di avvio.

    
risposta data MattCole3 04.05.2016 - 17:44
2

Ho trovato che le attuali correzioni non funzionano con la versione corrente di chrome, inoltre è necessario modificare altre cose (almeno per la mia configurazione).

Posso confermare che funziona (rimuove sia lo sfarfallio che lo strappo) - grazie a link

Computer: XPS13 9343 Grafica: 00: 02.0 Controller VGA compatibile: Intel Corporation Broadwell-U Integrated Graphics (rev 09) Versione di Chrome: versione 54.0.2840.100 (64-bit)

Impostazioni

1) Controlla i messaggi di errore prima e dopo le modifiche di configurazione di seguito

  • chrome: // gpu
  • prendi uno screenshot per poterlo confrontare dopo.

2) Modifica (per chrome): /usr/share/applications/google-chrome.desktop o per (cromo): /usr/share/applications/chromium-browser.desktop

  • Aggiungi i flag --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffer
  • la linea dovrebbe assomigliare a questa: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf aggiungi questo (potresti aver bisogno di creare il file):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Impostazioni dei flag di Chrome: chrome: // flags:

  • Abilita ("zero copy rasterizer"): chrome: // flags / # enable-zero-copy
  • Abilita (abilita l'elenco di visualizzazione in 2D): chrome: // flags / # enable-display-list-2d-canvas
  • Abilita ("Sostituisci elenco di rendering del software"): chrome: // flags / # ignore-gpu-blacklist
  • Abilita "Mostra elenco tela 2D"): chrome: // flags / # enable-display-list-2d-canvas
  • Abilita (chrome flag per lo scorrimento regolare in linux): chrome: // flags / # smooth-scrolling

5) Ho mantenuto le impostazioni di Chrome & gt; Avanzate & gt; Usa l'accelerazione hardware quando disponibile [ tieni selezionato ]. Se deselezioni questa performance veramente (anche se riduce lo sfarfallio ma non strappa), le opzioni sopra riportate hanno funzionato molto meglio per me.

6) Riavvia il computer.

7) Confronta le impostazioni. chrome: // gpu

Questo ha totalmente eliminato lo sfarfallio e lo strappo per me.

    
risposta data Amos Folarin 15.02.2017 - 15:27
1

Disattivare l'accelerazione hardware ridurrà le prestazioni del tuo browser per le pagine che hanno animazioni e altre attività intensive del processore.

Tuttavia, se nel tuo sistema non è installata alcuna GPU, l'approccio di disattivazione dell'accelerazione hardware suggerito da sgiri è meglio per te.

Ma ho una GPU NVidia installata nel mio laptop e sto usando il SO desktop di Ubuntu. Così ho installato il driver binario proprietario (versione 352.63). Ha funzionato per me, spero che funzionerà anche nel tuo sistema Ubuntu.

    
risposta data user4128091 23.08.2016 - 08:50

Leggi altre domande sui tag