Non è possibile installare Skype 4.3 su Ubuntu 14.04 a 64 bit

19

Prima di tutto, penso che questa domanda non sia duplicata, perché ho provato tutte le altre soluzioni che ho trovato qui, ma niente ha risolto il mio problema.

Uso Ubuntu 14.04 a 64 bit.

Ho provato fino ad ora: sudo apt-get install skype - & gt; Non ha funzionato. L'errore era:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Ho provato sudo dpkg add-architecture & amp; & amp; sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb ma non ha funzionato. L'errore era:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

Ho provato a utilizzare dopo sudo apt-get -f install ma non è stato risolto.

Ho provato a installare utilizzando Gdebi . L'errore era:

Cannot install 'libqtwebkit4:i386'

Ho provato ad installarlo usando Ubuntu Software Center . L'errore era:

Cannot install 'libqtwebkit4:i386'

Ho provato a cambiare il server in "Software e aggiornamenti". Ho provato a utilizzare "Main Server" e "Server per Stati Uniti". Ma non ha potuto risolvere il mio problema.

Qualcuno ha qualche idea su come risolverlo?

RISOLTO

Bene, ho formattato il mio pc e ho installato Skype prima di tutto. Probabilmente un'altra installazione che avevo fatto prima che l'installazione di Skype fosse il problema, credo.

Grazie persone!

    
posta z_inx 30.07.2014 - 20:29
fonte

9 risposte

32

Sto utilizzando 14.04 a 64 bit, ecco come ho installato.

Scarica skype 4.3 da qui , e io usato Gdebi, per installarlo e installato bene. se non hai Gdebi installato, premi Ctrl + Alt + T sulla tastiera per aprire Terminal. Quando si apre, esegui i comandi seguenti:

sudo apt-get install gdebi

Come ho già detto, non ho avuto alcun problema con il metodo di cui sopra. Un'altra cosa che puoi fare per correggere i pacchetti danneggiati, puoi fare

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

o

Vai a Gestore pacchetti sinaptici, se lo hai installato, vai a Modifica - & gt; Correggi i pacchetti danneggiati.

Un modo alternativo per installarlo è

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Dopo questo se si ottiene un errore come non è possibile installare "libqtwebkit4: i386" o qualche altro pacchetto, provare questo comando.

     sudo apt-get upgrade --fix-missing

Ti suggerirà di provare il seguente comando.

    sudo apt-get -f install

Dopo aver eseguito il comando sopra, prova ancora una volta il seguente.

sudo dpkg -i skype-install.deb

Per ulteriori dettagli, consultare il forum Skype ufficiale qui .

Spero che questo ti aiuti :)

    
risposta data Mitch 30.07.2014 - 20:44
fonte
4

Prima esecuzione:

sudo apt-get install -f

per installare i deps relativi all'OS 14.04LST 64 bit e quindi provare i comandi seguenti ... skype 4.3 si installa perfettamente

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Ha funzionato per me .... ;;;; :)

    
risposta data suri 05.08.2014 - 16:13
fonte
2

Esegui i seguenti comandi:

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Risolto il problema per me.

    
risposta data nick 05.08.2014 - 14:26
fonte
2

Passi:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
risposta data John Foley 21.10.2014 - 22:54
fonte
1

Ho incontrato lo stesso problema di Skype 4.3 su Ubuntu 13.10. Tuttavia, seguendo le istruzioni di cui sopra, Skype 4.2 mostra sempre, anche quando si rimuove skype prima di scaricare la versione più recente. Per funzionare, ho dovuto rimuovere il file di configurazione .Skype nella mia directory home:

rm -r ~/.Skype

Non preoccuparti, non perderai i tuoi contatti o altro. L'unico lieve fastidio che posso vedere che all'inizio alcuni dei tuoi contatti appariranno con il loro nome skype e non con il nome completo familiare.

    
risposta data Marc Corluy 25.08.2014 - 12:59
fonte
1

Nel mio caso ho lo stesso problema dal non seguire il principio RTFM :) Installato alcuni pacchetti da xorg-edgers e quindi non li abbiamo rimossi correttamente come si dice nel commento di installazione (cioè rimosso il repository ma non i pacchetti installati). Ciò ha causato un effetto domino che porta ad essere incapace di installare qualsiasi pacchetto dipendente dalla libreria i386 ...

L'ho trovato provando a installare pacchetti con aptitude che dettagliava direttamente i problemi (versioni diverse dei pacchetti a 64 bit). Poi ho aggiunto il repository xorg-edgers e l'ho rimosso correttamente con:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Spero che possa aiutare qualcuno ...

    
risposta data Karel Lenc 25.08.2014 - 19:42
fonte
1

Ho risolto esattamente questo problema abilitando "Aggiornamenti raccomandati (aggiornamenti attendibili)" nel pannello di controllo "Aggiornamenti del software", scheda "Aggiornamenti".

    
risposta data Douglas Held 24.11.2014 - 19:04
fonte
0

Ho eseguito l'upgrade alla versione 4.3.0.37 perché la versione 4.2.0.13 non mi consentiva di accedere più con l'errore "Impossibile connettersi" .

Sfortunatamente per me dopo ore di tentativi non sono riuscito a far funzionare pulseaudio sul mio sistema, solo ALSA sta funzionando, quindi ho eseguito il downgrade a 4.2.0.13

Per risolvere l'errore di accesso ho spoofato il numero di versione 4.2.0.13 con la versione più recente di 4.3.0.37 e il login funzionava di nuovo, problema risolto.

Quindi, per risolvere il problema, esegui semplicemente il downgrade a 4.2.0.13 e sostituisci la versione 4.3.0.37 , esci da Skype ed esegui questo comando:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

Dopo dovresti poter accedere normalmente.

    
risposta data mikelinux 12.08.2014 - 09:03
fonte
0

Per coloro che hanno provato tutto quanto sopra ma stanno ancora lottando (come me):

Il problema potrebbe essere solo il server che usi per l'aggiornamento di Ubuntu (era nel mio caso). Il server che stavo usando non aveva la definizione corretta di libqtwebkit4:i386 .

Per risolvere questo:

  • Apri Impostazioni di sistema
  • Software e amp; Aggiornamenti
  • scheda Software Ubuntu
  • Scarica da (Altro ... e seleziona Miglior server)

Aggiorna il tuo sistema con sudo apt-get update e poi:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Ha funzionato per me.

    
risposta data Raphael_b 15.05.2015 - 18:17
fonte

Leggi altre domande sui tag