Come si cambia la combinazione della tastiera della lingua?

84

Mi piacerebbe digitare l'ebraico in Ubuntu. Ho provato a scaricare il pacchetto in lingua ebraica e poi a impostare alt - shift come collegamento al layout-change nella sezione Opzioni di "Keyboard Layout".

Tuttavia, quando effettivamente preme alt - shift , non succede nulla. Come posso cambiare il mio layout di tastiera in ebraico?

    
posta Itay Moav -Malimovka 17.10.2011 - 15:34

8 risposte

95

Ubuntu 13.04 e precedenti

Sembra che tu abbia dimenticato un passaggio importante.

  1. Scarica il supporto per la lingua ebraica. Puoi farlo dalla sezione Installa / Rimuovi lingue di "Supporto lingua".
  2. Impostazioni di sistema - & gt; Layout della tastiera - & gt; "+" - & gt; "Ebraico" - & gt; Aggiungere
  3. Impostazioni di sistema - & gt; Layout della tastiera - & gt; Opzioni - & gt; Chiavi per cambiare layout - & gt; seleziona [alt] + [maiusc] (questo passaggio è facoltativo, solo se desideri quella scorciatoia da tastiera personalizzata)

Un'icona come questa dovrebbe apparire in alto a destra dopo il passo due:

Ubuntu 13.10 e successivi

A partire da Ubuntu 13.10, ora viene chiamato Impostazioni inserimento testo invece di Layout tastiera

Può essere raggiunto attraverso uno di questi metodi

  1. Passa attraverso Impostazioni di sistema - & gt; Inserimento di testo
  2. Uso dell'indicatore dell'app come mostrato nella schermata di seguito.

    
risposta data Jjed 17.10.2011 - 15:49
22

Per cambiare il layout della tastiera su Ubuntu 12.04

  1. vai a Impostazioni di sistema ...

  2. In Layout tastiera - fai clic su Opzioni ...

  3. In Tasto / i per cambiare layout : scegli la combinazione di tasti che desideri utilizzare.

risposta data Tusitas 02.06.2012 - 11:33
4

Sono completamente nuovo a Ubuntu, l'ho appena installato ieri e lo adoro, ma ho riscontrato lo stesso problema quando stavo cercando di usare le scorciatoie da tastiera per passare dal latino all'arabo, ma fortunatamente ho trovato la soluzione , ecco semplicemente cosa fare:

  

Impostazioni di sistema ... → Layout tastiera → (fare clic su "+" per aggiungere nuovi layout di lingua) → Opzioni ... → (fare clic su) "Tasto / i per modificare il layout" → (barrare) "Alt Alt + Maiusc + "→ Chiudi

    
risposta data ArabUbuntuer 03.10.2012 - 00:06
3

Sembra che tu abbia dimenticato di aggiungere il layout di tastiera in ebraico. Indipendentemente dal numero di lingue possibili, devi aggiungere tutte le lingue con cui vuoi scrivere nelle impostazioni della tastiera.

Qualcosa come: 3.- Impostazioni - & gt; Layout della tastiera - & gt; + - & gt; Ebraico - & gt; Aggiungere

    
risposta data Calabacin 17.10.2011 - 16:45
3

Verifica se hai già impostato questa combinazione in compiz-config. Eseguilo premendo Alt + F2 , quindi digita ccsm , quindi premi Invio . A volte il collegamento è già utilizzato da un altro programma, quindi non puoi utilizzarlo.

Inoltre, controlla se funziona utilizzando un'altra combinazione, ad es. CapsLock + Maiusc .

    
risposta data Exeleration-G 17.10.2011 - 15:45
3

In Ubuntu 12.04 LTS,

Vai alla finestra Opzioni di layout della tastiera Potrei selezionare Tasto / i per cambiare layout e contrassegnare l'associazione della mia scelta. Io uso Shift + CapsLock per attiva / disattiva il layout dalla tastiera stessa senza dover usare il cursore del mouse per selezionare il layout richiesto dall'indicatore del pannello. La stessa combinazione di tasti sembrava funzionare per servirsi o selezionare tra più layout. (Ma in Ubuntu 13.10 non è stato così facile.)

In Ubuntu 13.10,

Vai alla finestra delle impostazioni Tastiera , nella scheda Tasti di scelta rapida , seleziono Digitando . L'impostazione predefinita per Passa alla sorgente successiva è Super + SPAZIO che non sembra funzionare per me, quindi facendo clic su di essa e assegnandomi un Nuovo acceleratore ... , per passare al prossimo L ayout (ho usato Super + L ).

(Poi ho assegnato qualcosa di simile per Passa alla fonte precedente usando lo stesso layout preferito , e poi ho iniziato a testarli. Passare dal layout preferito all'alternativo ha funzionato, ma il contrario ha fatto non . Fai riferimento al passaggio successivo per la correzione.)

La correzione: dopo aver assegnato Super + L per "Passa alla sorgente successiva" usando il mio layout preferito (A) , ho cambiato il layout della tastiera nel layout alternativo (B) e poi assegnato la combinazione a "Passa al precedente source " (per il quale ho usato Shift + Super + L ). Poi li ho testati e funzionano bene. (Forse disabilitare "Passa alla fonte precedente" funzionerebbe anche.)

I nuovi acceleratori per le combinazioni chiave che ho usato assomiglia a questo:

Potrei quindi passare al layout (A) usando Super + L e tornare al layout (B) usando Shift + Super + L .

    
risposta data precise 29.03.2014 - 06:54
2

Se hai installato il supporto per la lingua dopo l'installazione della tastiera, potrebbe non esserci alcuna azione sulle combinazioni selezionate (come @OndrejCertik riportato sopra).

In questo caso dovresti reimpostare i valori di default del layout di tastiera di System Settings -> Keyboard Layouts -> Reset To Defaults e impostare Key(s) to change layout di nuovo sotto Options... lì.

    
risposta data hlopetz 17.01.2013 - 22:59
2

Impostazioni - & gt; Layout della tastiera - & gt; + - & gt; Arabo - & gt; Aggiungere

    
risposta data Abdennour TOUMI 16.05.2013 - 12:03

Leggi altre domande sui tag