Le chiavi del volume funzionano in unità ma non in xfce4

20

I miei tasti del volume non funzionano in xfce. Quando li ho usati mostra un'indicazione sullo schermo che il volume viene modificato, ma il volume non cambia affatto (stessa cosa con il tasto mute).

La cosa strana è che quando vado da xfce a ubuntu i tasti ora funzionano bene.

Non so se questo è importante ma ho una scheda audio nel mio computer.

Come posso far funzionare i tasti del volume in xfce?

    
posta skeept 15.05.2012 - 18:26
fonte

8 risposte

14

Questo è ancora rotto in 12.10. Puoi aggiustarlo installando xfce4-mixer e poi selezionando manualmente i mixer da controllare con esso - e poi andando nell'editor delle impostazioni di xfce4 e digitando il nome della "scheda attiva". Il pulsante di disattivazione audio non funzionerà correttamente, è possibile disattivare l'audio ma non riattivare il suono con esso. Tutto il resto funziona, comprese le notifiche sullo schermo. È davvero complicato far funzionare tutto, quindi ho aperto un bug: link

In dettaglio, in xfce4-mixer vuoi che assomigli a qualcosa del genere:

Questo dovrebbe mostrare solo il controllo del volume principale della tua scheda audio. Devi scegliere una scheda audio in alto e quindi fare clic su "Seleziona controlli ..." per aggiungere controlli. Quindi in xfce4-settings-editor è necessario impostare la "scheda attiva" in questo modo:

Sotto "schede audio" vedrai un elenco di ogni scheda audio per la quale hai aggiunto i mixer. Probabilmente avrai più carte, quindi potrebbero essere necessari alcuni tentativi per trovare quello giusto. Devi copiare il nome della carta corretta da "schede audio" a "scheda attiva" - questo sarà il mixer controllato dai pulsanti del volume.

    
risposta data Alistair Buxton 03.12.2012 - 01:20
fonte
5

xfce4-volumed funziona solo per me quando è non in esecuzione in modalità daemon. I tasti del volume funzionano per me quando eseguo questo comando per eliminare tutti i processi volumetrici esistenti e avviarne uno nuovo che non è in esecuzione in modalità daemon:

kill 'pidof xfce4-volumed' ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

Questo esegue il processo usando nohup, quindi il terminale in cui si esegue questo comando può essere chiuso senza uccidere il processo.

    
risposta data Stephen Ostermiller 20.02.2014 - 22:52
fonte
4

Quei tasti del volume sono basati su gnome ... o basati su unità o altro ... Devi creare scorciatoie da tastiera personalizzate nelle impostazioni della tastiera per ridurre, aumentare e disattivare il volume ... Per aumentare il volume, il comando è "amixer set master 5% +" per diminuire il volume "amixer set master 5% -" per disattivare "amixer set master toggle"

    
risposta data Arpit Roopchandani 19.05.2012 - 09:05
fonte
1

Ho avuto lo stesso problema in Xubuntu 12.04, anche se non so se avrebbe funzionato in Unity, dato che ho solo Xfce4. Nel terminale, digita:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Fonte: link

    
risposta data MrPink 07.06.2012 - 01:44
fonte
1

Se si tratta di un problema temporaneo, come nel mio caso, fallo semplicemente nella riga di comando:

killall xfce4-volumed && xfce4-volumed

    
risposta data Felipe 17.12.2015 - 17:56
fonte
0

Ho risolto il problema cambiando il parametro "Active Card" nell'editor xfce4-settings

Ho due schede audio (una HDMI e l'altra normale) e la scheda selezionata era diversa dalla normale scheda che stavo usando.

    
risposta data Damiano 30.12.2012 - 17:19
fonte
0

Ho avuto anche questo strano problema, potrei regolare il cursore del volume nel menu e non farebbe nulla. Inoltre, se provassi a regolarlo con la mia tastiera, il cursore si spostava ma non cambiava nulla con il volume effettivo.

L'ho risolto andando a PulseAudio Volumne Control . Nel pannello Output Devices , puoi vedere tutte le opzioni della tua scheda audio. Da lì, mi sono assicurato che la porta fosse impostata su Uscita analogica. Nel tuo caso potrebbe essere HDMI o cuffie a seconda di dove vuoi che il tuo suono vada. Quindi seleziona l'opzione "imposta come fallback". Sembra un segno di spunta verde.

I non ha installato xfce4-mixer per far funzionare tutto questo.

    
risposta data John 27.12.2014 - 21:27
fonte
0

In Settings > Settings Manager > Keyboard > Applications Shortcut :

  • aggiungi amixer set Master 3+ per aumentare il volume
  • aggiungi amixer set Master 3- per diminuire il volume
  • aggiungi amixer -D pulse set Master Playback Switch toggle per disattivare / riattivare l'audio
risposta data dr0i 09.03.2017 - 08:53
fonte

Leggi altre domande sui tag