Problema del touchpad: salto del cursore durante la digitazione (Ubuntu 14.04), syndaemon non aiuta

21

So che ci sono altre domande su questo problema, ma non riesco a trovare il giusto aggiustamento per sistemarlo.

Il touchpad rileva ancora i palmi durante la digitazione. È DAVVERO fastidioso, soprattutto perché rovina la mia produttività sul mio nuovo Dell XPS Gold Edition. Si tratta di una nuova installazione di Ubuntu 14.04 e non voglio gironzolare nel tentativo di script e roba che potrebbe finalmente interrompere il riconoscimento del touchpad.

Ho provato a utilizzare syndaemon perché sembra che sia la soluzione migliore per questo errore:

syndaemon -i 0.5 -d

Quando lo provo sul terminale, sembra funzionare fintanto che non esco dalla mia sessione.

Ma se inserisco il comando nella mia utility di programmi di avvio e riavvio, il cursore si blocca sempre dopo un minuto o due. Quindi devo deselezionare il comando usando la mia tastiera e sono tornato a questo fastidioso palmare. Qualche soluzione?

Alcune informazioni sul mio sistema:

greguti@greguti-XPS13-9333:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SYNAPTICS Synaptics Large Touch Screen    id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]
greguti@greguti-XPS13-9333:~$ xinput list-props "SynPS/2 Synaptics TouchPad" | grep -i finger
    Synaptics Finger (288): 25, 30, 0
    Synaptics Two-Finger Pressure (294):    282
    Synaptics Two-Finger Width (295):   7
    Synaptics Two-Finger Scrolling (298):   1, 1
    
posta greguti 07.05.2014 - 09:26
fonte

5 risposte

16

Non ho potuto seguire questa risposta con My XPS 13 e Ubuntu 14.04.

Ma ho trovato una soluzione rapida per disabilitare il touchpad durante la digitazione:

sudo apt-get install gpointing-device-settings

quindi esegui

gpointing-device-settings

Verifica: Attiva rilevamento Palm e sposta l'intervallo : stretto a circa il 10% dall'inizio.

    
risposta data valk 07.08.2014 - 11:56
fonte
8

Rispondendo alla mia domanda, suppongo di aver finalmente trovato la soluzione.

Sembra che il colpevole sia il driver stesso di Synaptics. Il frontend o il comando Wathever che si usa non funzionerà finché il driver non è stato riparato.

Grazie alla meravigliosa pagina web link e ad alcune e-mail con il proprietario, sono finalmente riuscito a risolvere questo terribile bug!

Quindi ecco il processo in un guscio di noce, fare riferimento alla pagina web sopra per i dettagli.

La cosa da fare per sbarazzarsi del driver Synaptics, quindi scaricare i sorgenti del driver upstream, applicarlo su patch per un corretto riconoscimento palmare e quindi creare il file con le giuste impostazioni per il touchpad. I seguenti passaggi funzionano bene con la mia XPS "Gold Edition" (xps-9333) di Dell con Ubuntu 14.04.

1. COSE DA CONTROLLARE PRIMA

Ho avuto un problema durante il processo a causa della mancanza di un pacchetto libevdev-dev nel mio sistema (suppongo che non sia installato con Ubuntu 14.04?). Quindi, per prima cosa, prova a installare questo pacchetto:

sudo apt-get install libevdev-dev

Se non è ancora presente sul tuo sistema, dovrebbe installare 3 pacchetti: libevdev-dev , libevdev2 {a} e libjs-jquery {a }

Un'altra cosa da fare è installare il pacchetto GIT, per consentire il download del codice sorgente del driver Synaptics upstream dai server GIT.

sudo apt-get install git

Una volta che questi pacchetti sono sul tuo sistema, puoi seguire questi comandi.

2. OTTIENI IL DRIVER DEL SINCRONISTO EFFETTIVO E INSTALLA IL PIANTA UPSTREAM

Inserisci i seguenti comandi nel Terminale (premi invio e verifica le uscite dopo ogni comando):

sudo aptitude purge xserver-xorg-input-synaptics

sudo aptitude build-dep xserver-xorg-input-synaptics

Il prossimo comando usa GIT. Se è la prima volta che lo usi, ti chiederà un indirizzo e un nickname per completare il processo (cioè, scarica il codice sorgente per il driver). Puoi farlo nel terminale, è un processo abbastanza semplice. L'output del comando ti dice cosa scrivere, devi solo seguire le istruzioni. Non ho mai usato GIT prima di me e potrei gestire questo passaggio molto facilmente.

sudo git clone git://anongit.freedesktop.org/xorg/driver/xf86-input-synaptics

Ora inserisci la cartella in cui è stato scaricato il codice sorgente:

cd xf86-input-synaptics

Ora scarica la patch per il nuovo driver, questa patch risolverà il driver abilitando il rilevamento del palmo e la larghezza del dito sul touchpad.

wget -q -O - http://xps13-9333.appspot.com/root/0001-Don-t-use-finger-width-for-the-palm-detection.patch | git am

Ora, crea il nuovo driver dal codice sorgente patchato (digita Enter dopo ogni riga, ogni comando produrrà un bel po 'di output):

./autogen.sh --prefix=/usr
make
sudo make install

Il tuo nuovo driver Synaptics, con la patch che consente il rilevamento dei palmi, è ora installato sul tuo sistema, ma devi comunque specificare le impostazioni che lo consentono.

3. CREA E MODIFICA 20-SYNAPTICS-CONF FILE

E ora per l'ultima parte, crea un file con le impostazioni per il touchpad, quel file verrà letto ogni volta che avvii il sistema.

Per prima cosa, crea la cartella giusta:

mkdir -p /etc/X11/xorg.conf.d/

Quindi scarichi il file fornito dal proprietario della pagina web menzionata in precedenza e lo copi nella nuova cartella appena creata:

sudo wget -q -O /etc/X11/xorg.conf.d/20-synaptics.conf http://xps13-9333.appspot.com/root/etc/X11/xorg.conf.d/20-synaptics.conf

Infine, puoi usare synclient per specificare il valore ottimale del parametro PalmMinZ (digita un numero invece di "VALUE", suggerisco 100, che funziona perfettamente per me).

synclient PalmMinZ=VALUE

Alla fine di questo processo, dovresti avere il nuovo file 20-synaptics.conf all'interno di /etc/X11/xorg.conf.d e il file dovrebbe apparire così:

4. NON DIMENTICARE DI RIAVVOLGERE:)

    
risposta data greguti 08.05.2014 - 13:29
fonte
6

Nessuna delle risposte qui stava funzionando per una nuova installazione di Ubuntu 14.04.3 su un XPS12, almeno fino a quando non ho inserito nella lista nera il modulo psmouse. Le seguenti istruzioni sono essenzialmente citate da questo insieme di istruzioni per una macchina XPS13 :

Controlla se il tuo touchpad utilizza solo il bus I2C e non la modalità ps2. Avvia un terminale e inserisci

 xinput 

Il puntatore del core virtuale dovrebbe avere solo due elementi:

 Virtual core XTEST pointer
 DLL0665:01 06CB:76AD UNKNOWN 

Se elenca un terzo elemento con il touchpad PS2 nel nome, dovresti inserire nella blacklist il modulo psmouse aggiungendo queste righe a /etc/modprobe.d/blacklist.conf :

# remove SynPS/2 Synaptics Touchpad because we want the mouse to work over IC2b
blacklist psmouse

Quindi chiama

sudo update-initramfs -u

Dopo il riavvio, l'opzione Disable touchpad while typing in System Settings / Mouse & Touchpad ha svolto il suo lavoro come previsto.

    
risposta data Communicative Algebra 21.01.2016 - 21:29
fonte
2

Se aggiungi syndaemon alle tue applicazioni di avvio, devi anche deselezionare "Disabilita durante la digitazione" in Mouse & amp; Impostazioni del touchpad. Se non lo fai, i due meccanismi interferiscono e fanno sì che il touchpad smetta completamente di funzionare come descrivi. Questo funziona per me a magazzino 14.04 (Lenovo T410 laptop) senza aggiornare il driver.

    
risposta data simonp 05.06.2014 - 13:15
fonte
0

L'aggiornamento menzionato da greguti è stato ora incorporato nell'aggiornamento generale del kernel per Linux alla 3.1.6+: vedi link .

Le istruzioni generali per aggiornare il kernel per Ubuntu possono essere trovate qui su link . Per un sistema generico a 64 bit, li ho copiati di seguito:

cd /tmp/
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600_3.16.0-031600.201408031935_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-image-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb
sudo dpkg -i linux-headers-3.16.0-*.deb linux-image-3.16.0-*.deb

E quindi riavvia.

Dopo il riavvio del mio computer, ho seguito il consiglio di greguit e ho modificato il parametro PalmMinZ. Ne ho usato anche 100.

synclient PalmMinZ=VALUE

Ho anche riattivato l'impostazione del trackpad da disabilitare durante la digitazione, utilizzando la GUI.

Ho speso solo 10-15 minuti usando il computer dopo averlo fatto, ma finora l'intera esperienza è molto meglio.

    
risposta data Andy Wickert 08.10.2014 - 17:40
fonte

Leggi altre domande sui tag