Voglio installare libssl.0.9.8

20

Sto cercando di installare il programma utorrent, e quando eseguo il programma ottengo

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Sto navigando nei diversi forum da ieri e non ho trovato nulla di utile fino ad ora, quindi per favore dimmi qual è il problema ??

    
posta Muhammad Jawabreh 08.11.2011 - 21:05

4 risposte

16

In generale dovresti cercare software attraverso il centro software o se ti piace la riga di comando, puoi usare apt-cache search . In questo caso, è apparso il seguente pacchetto (in 11.10): libssl0.9.8

Potresti provare a installarlo ( sudo apt-get install libssl0.9.8 ). Se questo non aiuta, potresti dirci, quale versione di Ubuntu stai usando.

    
risposta data xubuntix 08.11.2011 - 21:32
7

Se stai usando 11.10 (dato che non lo hai menzionato) allora hai libssl1.0.0 che è maggiore di 0.9.8. Qualsiasi programma che abbia bisogno di 0.9.8 sarà anche in grado di gestire versioni superiori a quella.

Se NON hai 11.10 hai diversi modi:

  1. Vai al sito OpenSSL: link e segui le installazioni lì.

  2. Vai a Pacchetti Ubuntu e scarica il .DEB da lì: link

  3. Vai ai pacchetti Debian e scarica il file .DEB da lì: link

  4. Installalo tramite apt-get o aptitude :

    • sudo apt-get install libssl0.9.8 - Per la versione 0.9.8
    • sudo aptitude install libssl0.9.8 - Per la versione 0.9.8
    • sudo apt-get install libssl1.0.0 - Per la versione 1.0.0
    • sudo aptitude install libssl1.0.0 - Per la versione 1.0.0
risposta data Luis Alvarado 08.11.2011 - 21:35
7

Nella versione a 64 bit di Ubuntu 12.04, ha funzionato per installare la versione a 32 bit:

sudo apt-get install libssl0.9.8:i386

Ma, naturalmente, quando sei su Ubuntu a 32 bit, questo dovrebbe funzionare (senza :i386 ):

sudo apt-get install libssl0.9.8
    
risposta data ayke 11.02.2013 - 00:44
0

Prova questa procedura quando ne hai bisogno per CAV per Linux.

Se hai già provato a installare cav ma c'è un errore con Libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Disinstalla tutto libssl0.9.8 da / con Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

e quindi installare il modo normale.

  1. Crea una directory /opt/COMODO

    Copia il file cav qui:

    cd /opt/COMODO
    sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb
    
  2. Scarica driver e ricostruzione del driver

    copiali in /opt/COMODO

    esegui la configurazione post:

    sudo /opt/COMODO/post_setup.sh
    
  3. Eseguilo solo se ricevi un errore che i moduli RedirFS non sono installati

    sudo bash /opt/COMODO/fix_rebuild_driver.sh
    sudo /opt/COMODO/post_setup.sh
    
  4. Reboot

risposta data JDoerr 28.08.2016 - 10:10

Leggi altre domande sui tag