Pidgin non mostra la lista degli amici?

19

Mi piace usare pidgin al posto di Empathy perché ci sono abituato, e perché devo avventurarmi in Windows per uno sviluppo maggiore di quello che preferirei.

In Ubuntu 11.10, non riesco a trovare alcun modo per arrivare alla lista degli amici. Si apre e si siede lì nella cosa del pannello del pannello di messaggi. Dal suo comportamento precedente, credo che Pidgin di solito si avvia minimizzato-- devi cliccare sulla sua barra delle applicazioni per mostrare la lista degli amici. L'applet messenger non sembra supportare questa funzionalità. È un bug o mi manca qualcosa di ovvio?

    
posta Nicholas Flynt 16.10.2011 - 05:12

10 risposte

10

Di fronte allo stesso problema. Completamente reinstallare (eliminare e reinstallare) pidgin e le sue dipendenze lo hanno risolto per me. Prova quanto segue in un terminale.

Elimina pidgin e le sue dipendenze:

$ sudo apt-get purge pidgin pidgin-libnotify pidgin-data indicator-status-provider-pidgin

Cancella archivi obsoleti:

$ sudo apt-get clean

Reboot.

Reinstalla la pidgin insieme alle dipendenze:

$ sudo apt-get install pidgin

Questo ha risolto il problema per me. Pidgin ora mostra l'elenco degli amici dal menu degli indicatori e quando lancio Pidgin manualmente.

    
risposta data kaustavdm 17.10.2011 - 20:11
14

Controlla il valore del parametro list_visible in .purple / prefs.xml , se è 0, chiudi pidgin, modifica e cambia in 1, quindi riavvia pidgin.

<pref name='list_visible' type='bool' value='1'/>

Puoi anche provare lo stesso con "blist_autohide"

<pref name='blist_autohide' type='bool' value='1'/>
    
risposta data George Brad 02.02.2012 - 14:39
6

Questo problema si verifica ancora il 12.04. A volte, l'unico modo per farlo funzionare è a killall pidgin e utilizzare il launcher dal cruscotto. Tuttavia, ho trovato una soluzione che funziona sempre.

Utilizza il seguente comando:

gksu gedit /usr/share/applications/pidgin.desktop (o usa il tuo editor preferito invece di gedit)

Aggiungi questo in fondo al file e salva:

X-Ayatana-Desktop-Shortcuts=List
[List Shortcut Group]
Name=Display Buddy List
Exec=pidgin %U
TargetEnvironment=Unity

Ciò che fa è un'opzione per il launcher di pidgin chiamato "Display Buddy List" che mostra sempre l'elenco quando selezionato. Ma, se la lista è già mostrata, non ne aprirà una seconda.

Quindi, per farla breve, se l'apertura di Pidgin dal menu di messaggistica ti dà quel problema, usa la soluzione elencata qui. Anche se non funziona facendo clic sull'opzione del menu di messaggistica o utilizzando il programma di avvio da Dash, funzionerà sempre.

Nota: a chi si chiede perché non ho consigliato di copiare l'avvio di Pidgin su .local/share/applications , è perché il launcher nel menu di messaggistica lancia /usr/share/applications/pidgin.desktop . Quindi, piuttosto che modificare il menu di messaggistica, ho consigliato di modificare il programma di avvio originale.

    
risposta data Ryan McClure 11.05.2012 - 06:58
3

Volevo solo menzionare che ho provato tutto quanto sopra e niente sembrava funzionare. Poi, quando sono entrato in Tools - & gt; Preferenze e deselezionata lo stato "Usa stato dall'ultima uscita all'avvio" e cambiato lo "Stato da applicare all'avvio:" a "Disponibile", le cose sembrano funzionare bene. Non sono sicuro del motivo per cui sembra averlo risolto, ma finora ho riavviato un paio di volte e sembra che funzioni adesso.

    
risposta data Neal Gamradt 15.11.2011 - 15:28
1

La rimozione della mia cartella ~/.purple ha risolto il problema per me, avevo copiato la mia cartella Inizio dalla 11.04 alla 11.10.

Attenzione: l'eliminazione di ~/.purple significa che dovrai configurare nuovamente account e preferenze.

Nota: dopo aver fatto questo ora anche a volte ho bisogno di caricare Pidgin con il flag -f per la lista degli amici da mostrare.

    
risposta data Sheldon 20.10.2011 - 03:27
1

Ho avuto lo stesso problema. Una cosa che ha funzionato per me era andare al menu "busta" di Unity (dove vengono mostrate le notifiche di posta elettronica e IM) e premere "Cancella". Quindi, tornando allo stesso menu, ho selezionato "Pidgin Internet Messenger" e improvvisamente è apparso l'elenco degli amici.

    
risposta data user1009080 29.11.2011 - 18:15
1

Ho avuto anche questo bug. Una cosa risolve il problema: impostazione "Mostra icona nella barra delle applicazioni" su "Sempre" nelle preferenze di pidgin. Non so perché o come, ma ora è tutto OK.

    
risposta data bolesky 01.12.2011 - 09:52
1

Non è necessario rimuovere la directory .purple

Questo ha funzionato per me:

sudo aptitude install --reinstall pidgin

Ciò manterrà le tue impostazioni in pidgin

    
risposta data rubo77 29.10.2015 - 14:27
0

Ho lo stesso bug sul mio pc, posso risolverlo temporaneamente con disabilitare e riattivare l'account nella voce del menu Account.

avvia pidgin con la chiave -f, sembra un bug che possa essere causato da network-manager. in gnome 3!

    
risposta data user28064 16.10.2011 - 22:16
0

Nessuna delle soluzioni ha funzionato per me, sembra che ci siano più persone come me a giudicare da questo bug: link (nel caso qualcuno si imbatta in questo)

    
risposta data sup 26.11.2011 - 13:16

Leggi altre domande sui tag