Si sono verificati errori durante l'elaborazione: man-db

20

Ottengo questo errore quando uso apt-get upgrade & apt-get autoremove e su ogni apt-get [Something].. e quando provo a installare anche le applicazioni:

Errors were encountered while processing:
man-db
E: Sub-process /usr/bin/dpkg returned an error code (1)
    
posta R9TySix 15.02.2012 - 18:45
fonte

6 risposte

15

Si prega di leggere i commenti qui sotto. Questo potrebbe essere un comando pericoloso da eseguire sul tuo sistema e creare uno stato irrecuperabile. (le righe sono state commentate per impedire il sysadmining di copia e incolla).

Semplice e funzionante l'ho provato !!

sudo -s
# cd /var/cache/debconf
# rm *.dat
apt-get update && apt-get upgrade

Divertiti;)

    
risposta data ucefkh 04.10.2013 - 03:40
fonte
12

Nessuna soluzione menzionata nelle risposte ha funzionato per me e ho provato una soluzione menzionata qui su Forum di Ubuntu , in esecuzione il comando

sudo dpkg -i --force-all [deb file path]

e ha funzionato.

    
risposta data Ravindra Gullapalli 29.03.2013 - 00:49
fonte
6

risposta wiki della comunità - risolto da OP

Questo problema è stato risolto eseguendo il seguente comando di terminale:

sudo dpkg-reconfigure -phigh -a
    
risposta data fossfreedom 27.02.2013 - 10:14
fonte
4

Potresti anche voler sapere che puoi usare dpkg --audit per vedere qual è il vero problema.

Se l'output è simile a:

The following packages are in a mess due to serious problems during installation. 
They must be reinstalled for them (and any packages that depend on them) 
to function properly:
  gcdemu A GNOME panel applet to control CDEmu daemon

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 cdemu-daemon CDEmu daemon
 cdemu-client A simple command-line client to control CDEmu daemon

The following packages are only half configured, probably due to problems
configuring them the first time. The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 transmission-daemon lightweight BitTorrent client (daemon)
 vhba-dkms VHBA virtual host bus adapter module

Potresti eseguire il comando: dpkg --configure <packagename>

 dpkg --configure cdemu-daemon

Per

Reconfigure an unpacked package. 
If -a  or  --pending  is  given instead of package, all unpacked but unconfigured
packages are configured.

Inoltre puoi usare:

sudo apt-get -f install
sudo apt-get --reinstall install gcdemu

Per sistemare i pacchetti in disordine.

Esempi da qui: link

    
risposta data First Name 05.09.2015 - 00:08
fonte
3

Devi eseguire quei comandi con sudo precedendoli in modo che possano essere eseguiti con credenziali di super utente Esempio:

sudo apt-get autoremove "NAME OF PACKAGE HERE"
    
risposta data Scott Stookey 15.02.2012 - 18:55
fonte
1

Se hai eliminato /var/cache in un tentativo errato di ripulire (come ho fatto io), questo potrebbe risolvere il problema (lo ha fatto per me):

sudo mkdir /var/cache/debconf
    
risposta data Matthias Braun 15.03.2014 - 15:01
fonte

Leggi altre domande sui tag