avvio del server mysql fallito

22

Sto usando il server Ubuntu. Quando ho provato ad accedere a mysql (che era in esecuzione), ho ricevuto il seguente errore

ERROR 2002 (HY000): Can't connect to local MySQL server through socket         '/var/run/mysqld/mysqld.sock' (2)

Ma il file mysqld.sock non esiste all'interno della cartella /var/run/mysqld . Eseguendo il comando ps aux | grep mysql , mi sono reso conto che il server mysql non era in esecuzione.

Ho quindi provato a riavviare il server mysql usando

service mysql start
service mysql restart
/etc/init.d/mysql start

Tuttavia, il processo di avvio è fallito in tutti e 3 i casi. /var/log/mysql/mysql.log e /var/log/mysql/mysql.err file sono vuoti.

Ma /var/log/error.log mostra le seguenti informazioni:

140425 12:49:05 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140425 12:49:05 [Note] Plugin 'FEDERATED' is disabled.
140425 12:49:05 InnoDB: The InnoDB memory heap is disabled
140425 12:49:05 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140425 12:49:05 InnoDB: Compressed tables use zlib 1.2.8
140425 12:49:05 InnoDB: Using Linux native AIO
140425 12:49:05 InnoDB: Initializing buffer pool, size = 3.0G
140425 12:49:05 InnoDB: Completed initialization of buffer pool
InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880 bytes
InnoDB: than specified in the .cnf file 0 26214400 bytes!
140425 12:49:05 [ERROR] Plugin 'InnoDB' init function returned error.
140425 12:49:05 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140425 12:49:05 [ERROR] /usr/sbin/mysqld: unknown variable 'record_buffer=64M'
140425 12:49:05 [ERROR] Aborting

140425 12:49:05 [Note] /usr/sbin/mysqld: Shutdown complete
    
posta ananth 25.04.2014 - 09:31
fonte

10 risposte

23

Apri un terminale ( Ctrl + Alt + t ) e fai quanto segue:

sudo service mysql stop
sudo rm /var/lib/mysql/ib_logfile0
sudo rm /var/lib/mysql/ib_logfile1

e commenta la riga record_buffer=64M in /etc/mysql/my.cnf [1 ]

e quindi riavvia msyql usando:

sudo service mysql restart

(Origine)

    
risposta data jobin 25.04.2014 - 10:36
fonte
8

Questo ha risolto il mio problema:

mkdir /var/run/mysqld

touch /var/run/mysqld/mysqld.sock

chown -R mysql /var/run/mysqld

/etc/init.d/mysql restart

    
risposta data user520064 12.11.2015 - 19:09
fonte
7

Ho risolto il problema nel modo seguente:

chown -R mysql:mysql /var/lib/mysql
mysql_install_db --user=mysql -ldata=/var/lib/mysql/

In un altro contesto, l'ho affrontato perché il demone mysql non è stato avviato. Quindi avvia demone con comando - mysqld start e poi prova ad avviare il servizio.

    
risposta data Sudheesh.M.S 27.03.2015 - 17:16
fonte
2

Ho avuto lo stesso messaggio di errore e lo stesso vuoto nei file di registro. Nel mio file di configurazione (my.cnf) avevo specificato che volevo usare le tabelle myisam, aggiungendo questa riga nella sezione [mysqld]:

default-table-type = myisam

Dopo l'aggiornamento di mysql sembra che questo non porti l'avvio a mysql. Ho cambiato questo in:

default-storage-engine = myisam

e ora tutto funziona bene.

    
risposta data Lars Olav Tveito 07.07.2015 - 12:16
fonte
1

Potrebbe anche essere utile aumentare la RAM disponibile aggiungendo un nuovo spazio di swap. I passaggi sono qui

Assicurati di creare / swapfile delle dimensioni inferiori allo spazio disponibile mostrato da

df -h

Ad esempio, per me l'output di df-h era:

Filesystem      Size  Used Avail Use% Mounted on
/dev/xvda1      7.8G  1.2G  6.3G  16% /
none            4.0K     0  4.0K   0% /sys/fs/cgroup
udev            492M   12K  492M   1% /dev
tmpfs           100M  336K   99M   1% /run

Così ho creato usando 2 G

sudo fallocate -l 2G /swapfile

E poi avvia il servizio

sudo /etc/init.d/mysql restart

Spero che questo aiuti. Tutto il meglio.

    
risposta data Vivek 21.06.2016 - 13:24
fonte
1

La mia soluzione:

Controlla se in /etc/rc1.d ... /etc/rc5.d lo script mysql inizia con S (Ex S10mysql) e non K AS K10mysql.

Spiegazione: il prefisso K viene caricato con stop, tipo di servizio kill; e il prefisso S inizia con il parametro start.

execute in terminal:   
(command        script action  runlevel)
---------------------------------------
sudo update-rc.d mysql enable  2
sudo update-rc.d mysql enable  3
sudo update-rc.d mysql enable  4
sudo update-rc.d mysql enable  5
    
risposta data Sergio Abreu 02.12.2016 - 08:58
fonte
0

Rimuovi il file /var/lib/mysql/.run-mysql_upgrade e dovrebbe iniziare

;)

"Con un grande potere derivano grandi responsabilità"

    
risposta data Adrian Pule 09.10.2014 - 01:26
fonte
0

Ho riscontrato questo problema quando ho impostato max_allowed_packet = 0.5M in /etc/mysql/my.cnf .

L'ho risolto cambiando max_allowed_packet in 1M .

    
risposta data Elliot Schep 13.09.2017 - 19:56
fonte
0

Il seguente comando risolve il mio problema e mysql potrebbe avviarlo dopo (potrebbe essere utile in alcuni casi)

chown -R mysql: /var/lib/mysql
    
risposta data zhilevan 10.12.2017 - 09:44
fonte
0

Nel mio caso, era un problema di spazio. Controlla se hai abbastanza spazio a disposizione.

da /var/log/mysql/error.log Ho ricevuto alcuni suggerimenti da due righe:

2018-08-04T05:25:29.519139Z 0 [ERROR] InnoDB: Write to file ./ibtmp1failed at offset 3145728, 1048576 bytes should have been written, only 704512 were writt$
2018-08-04T05:25:29.519145Z 0 [ERROR] InnoDB: Error number 28 means 'No space left on device'

Ho visto che si tratta di un problema di spazio.

root@xxx:/home/user1# df -h
Filesystem                            Size  Used Avail Use% Mounted on
udev                                  477M     0  477M   0% /dev
tmpfs                                 100M   11M   89M  11% /run
/dev/mapper/server1--osticket--vg-root  8.3G  7.9G     0 100% /
tmpfs                                 497M     0  497M   0% /dev/shm
tmpfs                                 5.0M     0  5.0M   0% /run/lock
tmpfs                                 497M     0  497M   0% /sys/fs/cgroup
/dev/vda1                             472M  467M     0 100% /boot
tmpfs                                 100M     0  100M   0% /run/user/1000

Da qui, ho potuto vedere che non c'era abbastanza spazio sul server virtuale /dev/mapper/server1--osticket--vg-root 8.3G 7.9G 0 100% / . E ho pensato di migrare o aumentare l'unità virtuale, ma ho deciso di rimuovere prima i file non necessari.

Quindi, ha dovuto pulire la cache e i file che non erano necessari:

#apt-get clean
#apt-get -f autoremove

Quindi, non dimenticare di rimuovere i file di log corrotti mysql in seguito. Verrebbero generati di nuovo quando si riavvia mysql

#service mysql stop
#cd /var/lib/mysql
#rm ib_logfile*
#service mysql start

Controlla il tuo servizio server mysql ed è probabilmente attivo e funzionante

root@server1-osticket:/var/lib/mysql# service mysql status
● mysql.service - MySQL Community Server
   Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-08-04 23:07:24 WAT; 7min ago
  Process: 1559 ExecStartPost=/usr/share/mysql/mysql-systemd-start post (code=exited, status=0/SUCCESS)
  Process: 1549 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
 Main PID: 1558 (mysqld)
    Tasks: 29
   Memory: 280.3M
      CPU: 589ms
   CGroup: /system.slice/mysql.service
           └─1558 /usr/sbin/mysqld

Aug 04 23:07:19 server1-osticket systemd[1]: Starting MySQL Community Server...
Aug 04 23:07:24 server1-osticket systemd[1]: Started MySQL Community Server.
root@server1-osticket:/var/lib/mysql#

Caso chiuso. Spero che aiuti.

    
risposta data sukupandachu 04.08.2018 - 20:40
fonte

Leggi altre domande sui tag