Strano sfarfallio dello schermo parziale dopo l'aggiornamento alla 14.04

20

Sono stato infastidito da questo problema già da alcune settimane. Il problema è iniziato quando ho aggiornato alla 14.04. Alcune parti del mio schermo a volte sfarfallano come mostrato in 2 video che linko di seguito:

link

link

Stavo provando a registrarlo con VLC ma improvvisamente quando inizio a registrare poi ... smette di sfarfallare :)

Non ho idea di dove posso presentare un bug per questo e su quale pacchetto può essere collegato. Si prega di commentare con cosa può essere collegato e come posso risolvere questo.

Pubblicherò qualsiasi informazione pertinente riguardante i pacchetti se necessario.

Uso nvidia-334 dal pacchetto xorg edgers ( 334.21-0ubuntu1~xedgers14.04.1 ) ma ho provato anche altri ed è lo stesso problema.

    
posta Patryk 20.05.2014 - 18:17
fonte

5 risposte

13

Questo ha funzionato per me: link

Attiva Forza il ridisegno a schermo intero sull'opzione di ridisegno in Soluzioni alternative

Ho avuto uno sfarfallio casuale simile a questo (ad esempio, parte della pagina web sfarfallata in Firefox (accelerazione hardware = attivata) o l'icona del desktop sfarfallio durante la deselezione) e questo ha risolto il problema.

Uso i driver Nvidia 340,58, Lenovo Y500 GT 750m (singolo, nessun ottimus, IntelHD disabilitato).

    
risposta data Lindza 22.11.2014 - 16:21
fonte
6

È un bug in Compiz. Se ti interessa, dovresti andare qui e fare clic su "questo bug mi riguarda" .

C'è una soluzione alternativa, ma può rendere il sistema un po 'più lento.

Installa CompizConfig Settings Manager , quindi vai a Composite e disabilita Unredirect fullscreen windows .

    
risposta data nastys 27.05.2014 - 20:55
fonte
6

Ho installato nvidia-331 (331.38-0ubuntu7) driver e per alcuni giorni non ho mai avuto problemi di sfarfallio, quindi probabilmente era un problema con i driver ( xorg-egders versione 334 o recente 337 )

    
risposta data Patryk 29.05.2014 - 12:15
fonte
4

Istruzioni complete basate sulle altre risposte qui:

  • Installa Compiz Config, da un terminale, digita:

    sudo apt-get install compizconfig-settings-manager

  • Dal launcher, esegui CompizConfig Settings Manager

  • Seleziona la casella di controllo in "Utility - & gt; Soluzioni alternative - & gt; Forza il ridisegno a schermo intero (buffer swap) sul ridisegno"

Ha funzionato anche per me, ho un laptop Dell XPS con una Nvidia GT 525m, usando Ubuntu 14.04.

    
risposta data Sebastián Ramírez 15.03.2015 - 14:06
fonte
-1

Ho avuto un problema molto simile con 2 GTX 680 in SLI e gli ultimi driver NVIDIA su una nuova installazione di Ubuntu in RAID-0. Mi sono ricordato che, prima dei driver Nvidia, lo schermo era molto solido e stabile con i driver dei nuovi nouveau.

Ma dopo i driver Nvidia, le cose sono andate male e lo schermo ha cominciato a lampeggiare. Mi sono ricordato di aver selezionato un passaggio nel programma di installazione di Nvidia per consentire all'installatore di generare il file xorgs.conf.

Ho rinominato xorg.conf in xorg.conf.bad-nvidia ora le cose sono belle e belle. Solo tu non hai bisogno che xorgs.conf venga creato da avvitatori nvidia.

    
risposta data Frustrated Nvidia user 06.08.2014 - 17:26
fonte

Leggi altre domande sui tag