Installazione grafica FGLRX proprietaria ATI / AMD non riesce, come posso risolvere il problema? [chiuso]

20

Voglio attivare il driver grafico FGLRX proprietario ATI / AMD (aggiornamento post-rilascio), ma c'è un problema durante l'installazione. Dice:

% Bl0ck_qu0te%

Come posso installare questo driver?

    
posta taha 13.11.2011 - 19:58
fonte

4 risposte

16

Rimuovi e elimina la versione corrente, quindi installa gli aggiornamenti:

  1. sudo apt-get --purge remove fglrx*
  2. sudo apt-get install fglrx-updates fglrx-amdcccle-updates
  3. Reboot

Assicurarsi che fglrx sia completamente rimosso è un passo importante. Non ha funzionato per me la prima volta che ho provato a installare gli aggiornamenti e alla fine ho rimosso ogni pacchetto fglrx singolarmente, eliminando ogni uno individualmente, rimosso non più dipendenze sudo apt-get autoremove , riavviato, quindi installato gli aggiornamenti sudo apt-get install fglrx-updates fglrx-amdcccle-updates , riavviato e (al momento della scrittura) Ho ottenuto catalyst versione 11.11 (che ancora non funziona con gnome3) .

12.10

  • 21 ott 2012 - fglrx non funziona in 12.10, vedi rapporto sui bug .
  • 4 gennaio 2013 - nessuna correzione ancora, bug rapporti sono in fiamme,
  • 27 luglio 2013 - Ancora nessun problema sospiro

12.10 Risoluzione dei problemi

Se hai problemi con la grafica dopo l'installazione o l'aggiornamento alla 12.10, dovrai rimuovere fglrx e utilizzare i driver open source:

    $ sudo apt-get remove fglrx*

Se rimani bloccato su un avviso relativo a "bassa grafica":

  1. Apri il terminale Ctrl + Alt + F1
  2. Rimuovi fglrx: sudo apt-get remove fglrx*
  3. Riavvio: sudo reboot

Per ulteriori informazioni, consulta la domanda SO Impossibile installare i driver proprietari ATI in 12.10 .

13.04

  • 27 luglio 2013 - fglrx non funziona. sospirare

Note

  • Quali pacchetti sono attualmente installati? % Co_de%

    $ dpkg -l fglrx*
    un  fglrx          <none>         (no description available)
    un  fglrx-amdcccle <none>         (no description available)
    ii  fglrx-amdcccle 2:8.911-0ubunt Catalyst Control Center for the AMD graphics
    un  fglrx-control  <none>         (no description available)
    un  fglrx-control- <none>         (no description available)
    un  fglrx-driver   <none>         (no description available)
    un  fglrx-kernel-s <none>         (no description available)
    un  fglrx-modalias <none>         (no description available)
    ii  fglrx-updates  2:8.911-0ubunt Video driver for the AMD graphics accelerato
    
  • Conferma che i driver funzionano dpkg -l fglrx*

    $ fglrxinfo 
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6300M Series
    OpenGL version string: 4.2.11733 Compatibility Profile Context
    
  • Per Catalyst & lt; = 11.11 con gnome & lt; = 3.2 Aspettatevi lo sfarfallio dello schermo e il sistema si blocca.

  • Driver display proprietario AMD Catalyst - Linux x86 & amp; Linux x86_64

  • Ottieni informazioni sul dispositivo: fglrxinfo o verbose lspci

risposta data Gerard Roche 13.04.2017 - 14:24
fonte
7

All Jockey fa installare fglrx e fglrx-amdcccle nel caso di driver normali e fglrx-updates e fglrx -amdcccle-updates quando selezioni l'opzione di aggiornamento post-rilascio, anche se in qualche modo fallisce perché non so quale motivo.

Puoi semplicemente installare / attivare l'opzione di driver di grafica FGLRX proprietario (aggiornamento post-rilascio) di ATI / AMD digitando la seguente riga nel terminale:

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

o cerca questi pacchetti all'interno del Software Center di Ubuntu e installali da lì.

    
risposta data Ravish Malik 16.11.2011 - 11:36
fonte
3

Una risorsa eccellente per l'installazione del driver più recente di ATI e facile da seguire. Installazione del driver più recente Catalyst da ATI in Ubuntu 11.10

Bob Bowles (a cura di): ho trovato il sito di download ATI molto user-friendly, con una buona autodocumentazione sul processo download / build / deploy. sito di download ATI .

    
risposta data duffydack 07.01.2012 - 23:12
fonte
0

Sul mio laptop T400, la scheda grafica ATI mobility radeon non è più supportata dall'ultimo driver fglrx 13.10.

(II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
   compiled for 1.4.99.906, module version = 13.10.10

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
$ lspci -n | grep 01:00.0
01:00.0 0300: 1002:95c4

Il file /var/log/Xorg.0.log mostra questa riga:

% Bl0ck_qu0te%

Risolto il downgrade e il blocco del pacchetto fglrx con synaptic manager: link

Come testo:

  1. avvia synaptic
  2. cerca il pacchetto fglrx
  3. scegli il menu Pacchetto - & gt; versione forzata
  4. dopo aver selezionato la versione precedente, fai clic su applica
  5. scegli il menu Pacchetto - & gt; versione di blocco

Ora anche Steam su Linux funziona di nuovo.

    
risposta data Joni Nevalainen 10.02.2014 - 11:43
fonte

Leggi altre domande sui tag