Dopo il riavvio, devo accedere ogni volta in Chrome

23

Se riavvio Ubuntu, devo accedere a ciascun sito e all'account Google Chrome. Qual è il motivo? Il mio sistema è Ubuntu 16.04 e Google Chrome 53.0.2785.101 (64-bit).

    
posta Novah 09.09.2016 - 07:28
fonte

6 risposte

15

Ho avuto lo stesso problema. Il mio sistema è Ubuntu 16.04 e Google Chrome 53.0.2785.101 (64-bit).

Ecco la mia soluzione:

  1. Vai a Impostazioni di sistema Ubuntu - & gt; Account online
  2. aggiungi il tuo account Google lì
  3. attivato lo switcher (non sono sicuro che sia necessario)
  4. accedi al browser Chrome e accedi di nuovo
  5. chiudi la finestra del browser

Nota : devi impedire l'esecuzione dei processi di Chrome dopo aver chiuso la finestra. Per fare questo vai su Impostazioni di Chrome & gt; Impostazioni avanzate (in basso) & gt; Deseleziona "Continua a eseguire app in background quando Google Chrome è chiuso"

Dopo averlo fatto, Chrome ha interrotto l'eliminazione dell'autenticazione dopo aver effettuato il logout in Ubuntu e anche dopo il riavvio

    
risposta data Igor Bukin 11.09.2016 - 23:34
fonte
5

Devi abilitare questa funzione nelle impostazioni di Privacy . Puoi arrivarci andando nelle impostazioni di Chrome:

Abilita salvataggio password

  1. Fai clic sull'icona del menu Chrome (i tre punti in alto a destra).
  2. Fai clic su Impostazioni
  3. Fai clic su Mostra impostazioni avanzate (nuova parte inferiore della pagina)
  4. (in Privacy - password e moduli ) inserisci i segni di spunta nel seguente modo:
    • Abilita il riempimento automatico per compilare moduli Web
    • Offerta Salva le tue password web

Le password possono essere salvate anche con i cookie disattivati. Puoi comunque controllare le impostazioni dei cookie con i passaggi seguenti.

Abilita o disabilita i cookie

  1. Fai clic sull'icona del menu Chrome
  2. Fai clic su Impostazioni
  3. Fai clic su Mostra impostazioni avanzate
  4. Nella sezione Privacy, seleziona Impostazioni contenuti
  5. Seleziona Consenti ai dati locali di essere impostati

Se sono state impostate tutte le impostazioni per il salvataggio delle password e non riesce ancora a controllare l'integrità delle impostazioni di Chrome, portalo alle impostazioni predefinite con i seguenti passaggi.

Prima uscita da Chrome. Quindi esegui questi comandi per rimuovere temporaneamente le impostazioni correnti.

$ cd ~/.config
$ mv google-chrome google-chrome.bak

Puoi ripristinare le precedenti impostazioni rinominando google-chrome.bak nel suo originale.

Il problema è stato risolto come descritto nella sezione commenti chat rinominando la home directory in un backup nome, quindi creando una nuova home directory in cui Google Chrome ha funzionato. Quindi la directory di backup è stata migrata nel nuovo spazio.

    
risposta data L. D. James 09.09.2016 - 08:47
fonte
2

Soluzione

Se la risposta di cui sopra non risolve il problema, l'installazione della versione beta di Google Chrome può risolvere il problema.

apt install google-chrome-beta  

Questo sembra non per risolverlo (voce conservata per ragioni storiche):

Ho lo stesso problema e ho fatto alcune ore di debug.

Il mio problema riguarda solo google-chrome-stable Versione 53.0.2785.101 (64-bit) su ubuntu 16.04.

Quando accedo a un sito Web, i cookie sono impostati correttamente. Quando chiudo Chrome, disconnetti, riaccedi, i cookie sono ancora lì e tutto va bene. Tuttavia, se I reboot , i cookie sono spariti e ho bisogno di accedere nuovamente.

Ho fatto un po 'di debug (reinstallando chrome, ripristinando la configurazione di default, partendo da una configurazione pulita, tutto come suggerito sopra, ...) e il bug persiste.

Ho installato google-chrome-unstable Version 55.0.2853.0 dev (64-bit) e tutto funziona correttamente (mentre lo stabile ha ancora il problema). Quindi questo è probabilmente un bug del software di Chrome.

La mia "soluzione": usa firefox / chrome-unstable per alcuni giorni / settimane, aspetta solo l'aggiornamento che risolve il problema di propagare a google-chrome-stable.

A proposito, sto usando Ubuntu 16.04 (systemd) con dm mapper / cryptsetup che è stato aggiornato dal 14.04 e non sono ancora sicuro al 100% che la mia partizione di crypt sia smontata ogni volta al 100% correttamente (anche se il file fs è sempre pulito). @Novah, hai una configurazione simile?

È settembre 2016 quando scrivo questo consiglio. Se non si è risolto entro un mese automaticamente, la mia risposta è sbagliata ;-) Spero di risparmiarti un sacco di debugging e frustrazione.

    
risposta data corny 09.09.2016 - 23:39
fonte
1

Tieni presente che questo è già segnalato al Chromium Bug Tracker: link

    
risposta data user597677 21.09.2016 - 21:50
fonte
0

Ho avuto lo stesso problema, ma il mio sistema è ubuntu 14.04.

Se il tuo sistema richiede anche la password per il keyring ogni avvio google chrome (anche riavvia il sistema), penso che Google Chrome non possa ottenere la tua password google salvata perché la tua password di google salvata è bloccata dal portachiavi. Devi assicurarti che il portachiavi sia sbloccato prima di avviare Google Chrome, non dopo. Ecco la mia soluzione:

  1. Apri google chrome.
  2. Accedi di nuovo all'account Google come di consueto e assicurati che non ci sia un'icona di avviso gialla prima del tuo nome utente nell'angolo in alto a destra. (fallo e basta)
  3. Chiudi google chrome.
  4. Apri Dash e apri Account utente, quindi attiva il login automatico "off".
  5. Riavvia il sistema.

Attivando il login automatico su "off", ho pensato che questo sbloccherà automaticamente il portachiavi ogni sistema di accesso, quindi Google Chrome può ottenere la password del tuo account Google dal portachiavi.

So che esiste anche un'altra soluzione su disabilitare il portachiavi (impostando la password del portachiavi in ​​bianco), ma penso che non sia sicuro.

    
risposta data mnemonic brian 18.10.2016 - 08:53
fonte
0

Stavo affrontando gli stessi problemi. Nella nuova installazione, ho installato Chrome come root (non sudo). Dopo il riavvio, il programma ha funzionato bene. Imparando questo, ho disinstallato Chrome dal PC precedente e l'ho reinstallato come utente root. Ora tutto è a posto e il fastidioso prompt di login è sparito.

sudo -i
apt-get remove google-chrome*
apt-get autoremove
apt-get clean  
apt-get install google-chrome-stable  
    
risposta data Vikas Avnish 30.12.2016 - 05:47
fonte

Leggi altre domande sui tag