Come risolvere problemi di wireless lento su macchine con schede wireless Intel?

21

Ho esaminato tutte le domande precedenti ma disattivando la gestione della potenza per la scheda Wi-Fi non funzionava. Questo problema sembra essere con il Lenovo Thinkpads. Sono passato a Ubuntu 11.10 da Windows 7 3 giorni fa quindi sono nuovo del sistema operativo.

    
posta Kaine McAliece 07.04.2012 - 02:18
fonte

8 risposte

20

OP pubblicato:

  • Nota 1: la connessione lenta può essere dovuta al fornitore di servizi o per qualsiasi altro motivo, per controllarla, provare la stessa rete da qualsiasi altro computer con diverso sistema operativo o connessione alla rete tramite un cavo. Se è veloce, questa soluzione può aiutarti. In caso contrario, può essere uno spreco di tempo! *

  • Nota2: nel primo collegamento dei Riferimenti che ho inserito, ci sono altri metodi per risolvere la connessione wireless lenta. Ogni metodo risolve diverse possibili ragioni della connessione lenta. Consiglio di testare la soluzione che ho inserito prima di cercare metodi diversi perché probabilmente è molto efficace. *

Se stai usando Ubuntu 11.10, fai quanto segue:

terminale aperto. Digita le seguenti due righe:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

Ora controlla la velocità della tua connessione a Internet. Se è ancora lento, questa soluzione probabilmente non è una soluzione per il tuo caso. In questo caso, riavvia il computer per ripristinare le modifiche apportate. Se diventa normale e veloce, fallo in modo permanente digitando la seguente riga nel terminale:

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

Un file verrà aperto. Alla fine del file, incolla la riga seguente, quindi salva:

options iwlagn 11n_disable=1

Dopo aver salvato, esci e GODITI!

Soluzione per Ubuntu 12.04:

terminale aperto. Digita le seguenti due righe:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Ora controlla la velocità della tua connessione a Internet. Se è ancora lento, questa soluzione probabilmente non è una soluzione per il tuo caso. In questo caso, riavvia il computer per ripristinare le modifiche apportate. Se diventa normale e veloce, fallo in modo permanente digitando la seguente riga nel terminale:

gksudo gedit /etc/modprobe.d/iwlwifi-disable11n.conf

Un file verrà aperto. Alla fine del file, incolla la riga seguente, quindi salva:

options iwlwifi 11n_disable=1

Dopo aver salvato, esci e GODITI!

References:

* Ho provato entrambe le soluzioni e funzionano.

    
risposta data Jorge Castro 05.05.2012 - 01:03
fonte
10

Ho risolto questo problema utilizzando le istruzioni qui .

in un terminale, scrivi:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

Per 12.04 e successivi: modifica options iwlagn 11n_disable=1 a options iwlwifi 11n_disable=1

    
risposta data eskararriba 11.04.2012 - 03:14
fonte
4

Per 12.04, cambia:

options iwlagn 11n_disable=1

A:

options iwlwifi 11n_disable=1
    
risposta data eskararriba 30.04.2012 - 20:52
fonte
3

Questo errore riguarda anche il mio laptop con Centrino Ultimate-N 6300. L'unica cosa che mi ha aiutato è stata l'attivazione del parametro swcrypto. Il mio /etc/modprobe.d/iwlwifi.conf ora si presenta così:

options iwlwifi 11n_disable=1 led_mode=1 swcrypto=1

E posso usare wifi senza problemi. Tuttavia, il fatto che le n-reti non possano essere usate rimane fastidioso.

    
risposta data Karl Frisk 02.08.2012 - 00:07
fonte
2

Questi comandi hanno aiutato e hanno funzionato per me, Kubuntu 15.10 (scaltro), il mio Intel Wifi Adapter (Intel Centrino Wireless-N 1000) è andato per lo più a tutta velocità da una scansione (velocità lumaca):

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlagn.conf
echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

All'inizio ho avuto così tante difficoltà a trovarlo, spero che aiuti qualcuno là fuori, è stato così lento all'inizio, quando ho installato Linux (Kubuntu), mi stava facendo impazzire:)

    
risposta data David V. 04.11.2015 - 03:48
fonte
1

AGGIORNAMENTO: In qualche modo è finito per non connettersi di nuovo quindi ho fatto più ricerche qui è quello che ho trovato:

Ripristina i comandi iwlwifi originali nel file iwlwif.conf (potrebbe non essere necessario ripristinare i comandi originali nel file iwlwifi.conf ) in /etc/modprobe.d/iwlwifi.conf e incollato questa riga alla fine:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Per ripristinare il file puoi creare un nuovo file di testo nei tuoi documenti chiamato iwlwifi.conf e aggiungere le righe di comando:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Quindi salva il documento ed esegui konsole e inserisci i comandi

sudo cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf

Dopo che il mio wifi ha iniziato a funzionare più velocemente di prima, quando ho inserito:

options iwlwifi 11n_disable=1

Nota: quanto sopra ha funzionato per me, dove ho copiato il file usando superutente. Non ho seguito questa parte ma potrebbe funzionare o meno.

Potrebbe essere necessario possibilmente eseguire i comandi come:

echo options options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Stavo ancora ricevendo il modulo di errore iwlwifi in uso quando eseguivo in precedenza:

sudo modprobe -rfv iwlwifi.

Fammi sapere se questo funziona per te o no nei commenti.

    
risposta data David V. 07.11.2015 - 07:02
fonte
1

Apri un terminale ( Alt + Ctrl + T ) e digita:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Ora controlla se le velocità sono migliorate. Se sì, rendilo permanente.

  1. Apri /etc/modprobe.d/iwlwifi_disable11n.conf come superutente, e. g:.

    gksudo gedit /etc/modprobe.d/iwlwifi_disable11n.conf
    
  2. Aggiungi la seguente riga alla fine del file:

    options iwlwifi 11n_disable=1
    
  3. Dopo, salvalo e chiudi!

In caso di errore come

ERROR: Removing 'iwlwifi': No such file or directory

sostituisci iwlwifi con iwlagn nei comandi precedenti e riprova.

    
risposta data Mukund 20.12.2012 - 17:47
fonte
0

Dopo diversi anni di impossibilità di utilizzare 801.11n sul mio portatile. Ho trovato una soluzione che risolve veramente questo problema! Questa sembra essere la migliore soluzione possibile perché puoi ancora utilizzare bluetooth e anche accedere alle reti tramite 801.11n senza problemi (sto ricevendo ~ 70 Mbps).

Inserisci i seguenti comandi in un terminale:

echo options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi-disable11n.conf

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Ecco una spiegazione di ciò che stiamo facendo:

  • swcrypto=1 cambia la crittografia hardware per la crittografia del software.
  • bt_coex_active=0 disattiva la funzione di interferenza automatica tra bluetooth e wifi - questa è probabilmente la vera causa dei problemi.
  • 11n_disable=8 consente l'aggregazione TX AMPDU.

Ciò che bt_coex_active effettivamente fa quando è abilitato è essenzialmente "silenziare" il wifi ogni volta che il sistema pensa che la frequenza bluetooth sia usata - ma in implementazioni buggy, si presume che il bluetooth stia sempre trasmettendo, limitando così il wifi in modo permanente.

La maggior parte delle persone sceglie di cambiare il file predefinito /etc/modprobe.d/iwlwifi.conf ma personalmente preferisco metterlo in un file separato in modo che possa essere annullato se necessario. Se hai provato modifiche precedenti, controlla che il tuo file sia ripristinato alle impostazioni predefinite. Per riferimento il mio è (su Ubuntu 16.04):

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Se ciò non funziona per te, esegui:

sudo rm /etc/modprobe.d/iwlwifi-disable11n.conf

Fonti:

  • link
  • centrino-6235-slow-freeze

link

Uso personale (la tua milizia può variare):

  • OS: Ubuntu 16.04 (funzionerà anche su versioni più recenti e più vecchie!)
  • Hardware: Intel Centrino Wireless-N 1000 [Condor Peak] Intel (ma funzionerà su modelli simili, ad esempio Intel Centrino 6235!)
risposta data hazrpg 23.05.2017 - 03:15
fonte

Leggi altre domande sui tag