Come faccio a rendere Sublime Text 2/3 non aprire le schede precedenti quando lo avvio?

19

Ogni volta che apro Sublime, queste schede si aprono automaticamente. Come posso risolvere questo problema. Non riesco a trovare alcuna impostazione per questo.

    
posta BigSack 25.08.2012 - 04:37
fonte

3 risposte

16

Testo sublime 2

Controlla il contenuto della directory ~/.config/sublime-text-2/Settings per un file chiamato Session.sublime_session

Se quei file sono inclusi, rimuovili

Testo sublime 3

ST3 memorizza i file di sessione sotto:

~/.config/sublime-text-3/Local/Session.sublime_session
    
risposta data Adonis K. Kakoulidis 25.08.2012 - 05:00
fonte
42

In realtà esiste una soluzione migliore implementata in Sublime Text. Seleziona Preferences-> Settings - User e imposta remember_open_files e hot_exit su falso. Il file risultante dovrebbe apparire così:

{
    "remember_open_files": false,
    "hot_exit": false
}

(Tutte le impostazioni possibili possono essere visualizzate in Settings - Default .)

In seguito riavvia il testo Sublime (potrebbe essere necessario riavviare il programma due volte, una volta per applicare le impostazioni) e dovrebbe avviarsi senza file aperti.

Nota: ho potuto testare questo solo con Sublime Text 3, ma sono abbastanza sicuro che queste impostazioni esistano anche nella versione 2.

    
risposta data Adam S 15.03.2013 - 18:48
fonte
1

In Testo sublime 3 , sotto ho lavorato per me.

  

$ rm ~ / .config / sublime-text-3 / Local / Auto \ Save \   Session.sublime_session

    
risposta data BTR Naidu 15.11.2017 - 09:15
fonte

Leggi altre domande sui tag