Come disabilitare lightdm?

20

Voglio disabilitare lightdm dall'autostart. Al momento, eseguo service lightdm disable dal terminale, quindi eseguo startx .

update-rc.d non aiuta     

posta Samat 18.05.2012 - 18:16
fonte

5 risposte

19

lightdm viene avviato da Upstart, non da SysV Init. Quindi update-rc.d non funziona.

Usa

 echo  "manual" | sudo tee -a /etc/init/lightdm.override
    
risposta data Florian Diesch 18.05.2012 - 18:42
fonte
21

Si noti che il metodo descritto sopra non funziona più dal 15.04 in poi, poiché Upstart è stato sostituito da Systemd. Come descritto qui , ora puoi disabilitare lightdm in questo modo:

16.04 in su

systemctl disable lightdm.service

15.04, 15.10

systemctl disable lightdm
    
risposta data Wolfgang Noichl 06.11.2015 - 14:10
fonte
4

Se si desidera disabilitare lightdm per abilitare gdm o kdm o qualsiasi altro display manager, immettere il seguente comando nel terminale:

sudo dpkg-reconfigure lightdm

Quindi inserisci ok e quindi seleziona dall'elenco il display manager desiderato.

La stessa risposta con gli screenshot è riportata qui: Ripristina login di unità di default

    
risposta data Nirmik 18.05.2012 - 18:30
fonte
1

Ho appena rimosso il bit di esecuzione sul file binario di lightdm.

chmod -x /usr/sbin/lightdm

Quindi riattivalo:

chmod +x /usr/sbin/lightdm

    
risposta data John 10.10.2015 - 21:10
fonte
0

Questo è gestito da display-manager ... Disabilita su systemd e il gioco è fatto.

# systemctl disable display-manager        
Removed symlink /etc/systemd/system/display-manager.service.
    
risposta data Trunet 14.07.2016 - 16:00
fonte

Leggi altre domande sui tag