Come riattivare i tasti funzione in byobu?

21

Stavo usando byobu su Ubuntu 11.10 Server e avevo bisogno di premere un tasto funzione in un'app, quindi ho premuto F9 per richiamare il menu di configurazione e ho cambiato il set di tasti da "f-keys" a "screen-escape- chiavi". Ha funzionato, ma ora non posso riattivare tutti i tasti funzione.

Ho trovato un programma byobu-config che richiama di nuovo il menu e posso tornare ai tasti dello schermo da lì. Questo risolve le cose per i nuovi processi dello schermo, ma l'effetto sulla sessione corrente dello schermo è strano: disabilita i tasti ctrl-a (schermo) e ripristina F2-F8, ma F9-F12 continua a non fare nulla (sono solo passato al processo in primo piano).

Che succede con questo? Qualche idea? Grazie in anticipo.

    
posta Yang 20.11.2011 - 06:47
fonte

5 risposte

27

Nota: questo solo funziona se stai utilizzando Byobu con tmux come back-end. Vedi altre risposte per Byobu con screen come back-end.

Premi Maiusc + F12 per attivare e disattivare i tasti F.

Esempio: avvia htop (all'interno di un riquadro Byobu ovviamente) quindi inserisci Maiusc + F12 , quindi se premi F3 cercherai in htop processi, non passa alla finestra / riquadro Byobu di sinistra.

domanda correlata con risposta anche per screen .

    
risposta data yPhil 01.10.2012 - 10:49
fonte
13

Puoi anche alternare le associazioni f-keys e le associazioni screen-escape-keys usando:

ctrl-a-!
    
risposta data Dustin Kirkland 28.02.2012 - 05:33
fonte
3

Possiamo tentare di eseguire il debug del tuo particolare problema, tuttavia sarebbe molto più semplice pulire semplicemente la tua configurazione Byobu e iniziare a pulire:

rm -rf ~/.byobu

Alla 11.04, dovrai anche rimuovere la cartella che questo collegamento simbolico punta a:

rm -rf ~/.local/share/byobu

E quindi avvia byobu .

    
risposta data Dustin Kirkland 17.02.2012 - 05:35
fonte
0

Nel caso in cui una delle combinazioni di tasti delle altre risposte non funzionasse, basta provare questo comando equivalente all'interno di Byobu:

byobu-keybindings
    
risposta data Leo 17.11.2017 - 15:10
fonte
0

Rendi la tua ~/.byobu/keybindings simile a questa:

# source $BYOBU_PREFIX/share/byobu/keybindings/common
. /usr/share/byobu/keybindings/f-keys.screen.disable

e seleziona lo schermo come back-end di byobu tramite byobu-select-backend . Questo funziona in Debian, almeno.

    
risposta data user156504 07.05.2013 - 18:36
fonte

Leggi altre domande sui tag