VLC media player non sta visualizzando video, ma l'audio funziona

24

Recentemente ho installato VLC media player dal Software Center di Ubuntu. Ha funzionato per un po ', ma poi al posto del video, è stato visualizzato solo uno schermo vuoto con l'audio. Anche gli stessi video che potrebbero essere riprodotti prima non funzionavano.

Ho provato a disinstallarlo e reinstallarlo, e l'ho aggiornato al più tardi.

Ho provato: menu Strumento Preferenze Video → abilitando Uscita video accelerata (Sovrapposizione) .

Anche l'esecuzione tramite terminale dà lo stesso risultato.

Sto usando Ubuntu 14.04 (Trusty Tahr).

    
posta clover13 03.09.2015 - 15:21
fonte

11 risposte

41
    • Vai a Strumenti Preferenze Video
    • Rimuovi il segno di spunta per Accelerated video output (Overlay)
    • Prova a riprodurre di nuovo il film, ora dovresti vedere l'output.

o

2.

  • Vai a Strumenti Preferenze - & gt; Video
  • Cambia Output in X11 Video output

Se quanto sopra non funziona, quel particolare video potrebbe avere un formato video proprietario che non è supportato.

Riferimento qui .

    
risposta data Ravan 03.09.2015 - 15:54
fonte
5

Inoltre, questo è successo a me, ma ...

vai a:

: menu Strumento → Preferenze → Video

Controlla il menu a discesa dell'output

e controlla di aver scelto il codec di output appropriato, è stato impostato su "auto" nel menu a discesa e doveva essere selezionato "X11"

    
risposta data user1526569 28.06.2017 - 03:56
fonte
2

La mia soluzione è cancellare il file di configurazione VLC. Apri un terminale in ~/.config/vlc e

rm vlc-qt-interface.conf

Cosa strana, se cancello il file di configurazione con il gestore di file Nautilus: ancora nessuna finestra.

    
risposta data JvdH 27.03.2017 - 23:24
fonte
1

Ho avuto lo stesso problema con l'installazione di Ubuntu 16.04 e VLC nuovi. La mia scheda video è NVidia e stavo usando la versione del driver proprietario binario 361.42 Sono passato alla versione 340.96 dello stesso driver e ho ottenuto il video senza problemi.

Spero di aver aiutato.

    
risposta data Замфир Йончев 09.10.2016 - 23:19
fonte
1

Ho notato questo problema da un paio d'anni e ho notato questo modello e un work-around:

  • Se VLC è ridotto a icona quando viene chiamato per riprodurre un file, il video non funzionerà: verrà visualizzato come vuoto / nero.
  • Se VLC è non minimizzato quando viene chiamato per riprodurre un file, il video funziona perfettamente.

La soluzione è assicurarsi che VLC sia non minimizzato quando gli dai un file da riprodurre.

Come ho trovato questo: ho un file di playlist sul desktop. In genere, preme il pulsante "Mostra desktop" per ridurre a icona tutte le finestre prima di eseguire quel file di playlist. Se VLC era già aperto, ora è ridotto a icona. Se apro il file della playlist, le finestre VLC si apriranno di nuovo, ma il video fallirà.

Tuttavia, se mi assicuro di riportare VLC allo stato di finestra prima che apre il file della playlist, il video funziona.

    
risposta data Davem753 27.01.2017 - 18:28
fonte
1

Se il VLC funziona ancora senza video, il problema può essere dovuto al codec video incompatibile contenuto nei file. In questo caso, forse è necessario convertire il file in formato video VLC più supportato. Puoi scegliere il convertitore video Makemkv o Pavtube, entrambi potenti strumenti video.

    
risposta data kolli 22.05.2017 - 03:43
fonte
1

Sto usando Ubuntu 16.04 e aggiornato a vlc 2.2.7 ha avuto lo stesso problema dopo aver aggiornato l'aggiornamento.

Vai a Strumenti & gt; preferences & gt; video & gt; output e seleziona una delle prime tre opzioni che terminano in (XCB). Risolto il problema per me.

Puoi anche provare una delle opzioni OpenGL e funzionano anche.

Spero che funzioni per te.

bidello -

    
risposta data infojanitor 06.04.2018 - 15:59
fonte
0

Questo è successo a me quando ho cancellato per errore libavcodec (probabilmente è stato preso di mira da apt-get autoremove dopo aver cancellato qualche altro pacchetto). Nel mio caso nessun giocatore (ho provato vlc, xplayer, smplayer) eccetto che i browser non erano in grado di riprodurre alcun video (ho provato per mp4, avi, mkv) ma l'audio ha funzionato. La reinstallazione di questo pacchetto ha risolto il mio problema. Quindi controlla se è installato.

    
risposta data Herman Yanush 30.06.2017 - 12:25
fonte
0

Nessuno di questi ha funzionato per me, ma un "segno per reinstallare" in synaptic ha fatto il trucco.

    
risposta data plrndl 27.08.2017 - 02:40
fonte
0

Correzione facile e non hai bisogno di ascoltare quanto sopra. Vai in VLC e vai in basso a destra, dove si trovano i 3 punti e vai alle impostazioni. Quindi vai alle impostazioni video e disattiva la decodifica hardware. Problema risolto

    
risposta data Billy 24.06.2018 - 07:41
fonte
0

Puoi provare anche questo (l'ho fatto in Ubuntu 16.04.03)

disinstallare VLC, quindi aprire la finestra del terminale e digitare:

sudo add-apt-repository ppa:videolan/master-daily

then:

sudo apt-get update

e poi:

sudo apt-get install vlc

funziona per me, quindi spero che tu possa averlo.

    
risposta data Latinbooker 02.02.2018 - 06:31
fonte

Leggi altre domande sui tag