netbeans non tutti i moduli richiesti possono essere abilitati

26

So che questa domanda è già stata pubblicata, ma le soluzioni fornite non funzionano per me. Ho aggiunto il repository webupd8team/java e installato oracle-java8-installer e oracle-java8-set-default . Ho scaricato netbeans 8.1 da netbeans.org (versione completa), l'ho installato, ma quando si tratta di abilitare i moduli java fallisce, mostrandomi una lista di tutti i moduli che i netbeans non possono abilitare.

Ho anche eseguito sudo update-alternatives --config java , che produce

  0            /usr/lib/jvm/java-8-oracle/jre/bin/java   1         auto mode
* 1            /usr/lib/jvm/java-8-oracle/jre/bin/java   1         manual mode

Sembra che JDK sia mancante.

Ottengo l'output corretto quando eseguo sia java -version che javac -version

Ho anche provato a eseguire il comando netbeans --jdkhome /usr/lib/jvm/java-8-oracle , senza successo. Viene visualizzato un messaggio di errore che dice che netbeans non è installato.

Ora, tutto questo accade solo con la versione che ho scaricato dal sito web. Quando installo netbeans dalla shell ( sudo apt-get install netbeans ) tutto funziona perfettamente.

Il fatto è che ho bisogno della versione completa dal sito Web, perché sto lavorando con supporto per server HTML5, CSS, J2EE e GlassFish.

Tutti gli aiuti sono apprezzati.

    
posta Jonathan De Felice 26.03.2016 - 21:27
fonte

4 risposte

49

Vai a / etc e apri netbeans.conf .

  

Nota : puoi trovare con ls -l $(which netbeans)

Assicurati che la variabile netbeans_jdkhome abbia il valore corretto, qualcosa del tipo:

netbeans_jdkhome="/usr/lib/jvm/java-8-oracle"
    
risposta data Minas Mina 26.03.2016 - 22:19
fonte
1

Modifica /usr/local/netbeans-X.Y/etc/netbeans.conf per contenere

netbeans_jdkhome="/usr/lib/jvm/java"

O usa il comando:

/usr/local/netbeans-X.Y/bin/netbeans --jdkhome /usr/lib/jvm/java
    
risposta data Prakash 06.12.2016 - 22:10
fonte
0

modifica il file /usr/local/netbeans-X.Y/etc/netbeans.conf

netbeans_jdkhome="/usr/lib/jvm/java-8-openjdk-amd64"
    
risposta data Joyy 22.02.2018 - 20:37
fonte
-1

Disinstalla e installa con JVM selezionata

link

    
risposta data Vitalicus 05.03.2018 - 12:26
fonte

Leggi altre domande sui tag